aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cscope
diff options
context:
space:
mode:
authorCliff Free <nucular.limozeen@gmail.com>2016-09-17 15:12:04 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-19 15:26:35 +0000
commit870c4c31442e33cf6628aba4a68d997a4448c789 (patch)
tree3f51a539febebcdf25fbc8fea38ebc35c9c1a9e5 /testing/cscope
parente768b060931579d34456fb7fa2bc0c743e33bdb4 (diff)
downloadaports-870c4c31442e33cf6628aba4a68d997a4448c789.tar.bz2
aports-870c4c31442e33cf6628aba4a68d997a4448c789.tar.xz
testing/cscope
http://cscope.sourceforge.net Cscope is a developer's tool for browsing source code.
Diffstat (limited to 'testing/cscope')
-rw-r--r--testing/cscope/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/cscope/APKBUILD b/testing/cscope/APKBUILD
new file mode 100644
index 0000000000..0214ef77d8
--- /dev/null
+++ b/testing/cscope/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Cliff Free <nucular.limozeen@gmail.com>
+# Maintainer:
+pkgname=cscope
+pkgver=15.8b
+pkgrel=0
+pkgdesc="Cscope is a developer's tool for browsing source code."
+url="http://cscope.sourceforge.net/"
+arch="all"
+license="BSD"
+depends="ncurses"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/cscope/cscope/$pkgver/cscope-$pkgver.tar.gz"
+builddir="$srcdir/cscope-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="8f9409a238ee313a96f9f87fe0f3b176 cscope-15.8b.tar.gz"
+sha256sums="4889d091f05aa0845384b1e4965aa31d2b20911fb2c001b2cdcffbcb7212d3af cscope-15.8b.tar.gz"
+sha512sums="3ebb9cc5bc814c02edb3e395a48e6fe2f206dd698529582e7df81755b335e8c3f4477ad4e8abcefd16d4d9adfd72981916322756b7060acf38fc82d56cc97fd5 cscope-15.8b.tar.gz"