aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dvdbackup
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-12 14:29:18 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-12 14:35:34 +0000
commit2cf06fd347be031ed1c646631c38295cd80b6bec (patch)
treec742a7e2b18c5ad04deb6d790b20dbfdcaa2215e /testing/dvdbackup
parent067e275675e1f83aebaa1cbffd977148b262f0e0 (diff)
downloadaports-2cf06fd347be031ed1c646631c38295cd80b6bec.tar.bz2
aports-2cf06fd347be031ed1c646631c38295cd80b6bec.tar.xz
testing/dvdbackup: new aport
Command line tool for DVD backups
Diffstat (limited to 'testing/dvdbackup')
-rw-r--r--testing/dvdbackup/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/dvdbackup/APKBUILD b/testing/dvdbackup/APKBUILD
new file mode 100644
index 0000000000..d51a735919
--- /dev/null
+++ b/testing/dvdbackup/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=dvdbackup
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="Tool to rip video DVDs from the command line"
+url="http://dvdbackup.sourceforge.net/"
+arch="all"
+license="GPL"
+makedepends="libdvdread-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/dvdbackup/dvdbackup-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="df9abb2ca0b8a7cd7855ddff94dae249b06b2ec0ee42f3e9c53aa46aebd9885bdf26dacecbd4a20ff5f642ea10c0c64b811d25c23802c8a2b1489281900fbe0d dvdbackup-0.4.2.tar.xz"