aboutsummaryrefslogtreecommitdiffstats
path: root/testing/e2fsimage
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-19 08:37:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-19 10:25:13 +0000
commiteeb37847cbe24199edda4b1d0ed946617cbf5c4a (patch)
treec3339da78d2cf43843537e4250497fc5141f9893 /testing/e2fsimage
parent06d873c35d45649783f1d3393b35034356679424 (diff)
downloadaports-eeb37847cbe24199edda4b1d0ed946617cbf5c4a.tar.bz2
aports-eeb37847cbe24199edda4b1d0ed946617cbf5c4a.tar.xz
testing/e2fsimage: new aport
create and populate an ext2/3/4 filesystem image as non-root user. https://github.com/Ledest/e2fsimage
Diffstat (limited to 'testing/e2fsimage')
-rw-r--r--testing/e2fsimage/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/e2fsimage/APKBUILD b/testing/e2fsimage/APKBUILD
new file mode 100644
index 0000000000..18036a76f5
--- /dev/null
+++ b/testing/e2fsimage/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=e2fsimage
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="create and populate an ext2/3/4 filesystem image as non-root user"
+url="https://github.com/Ledest/e2fsimage"
+arch="all"
+license="BSD"
+makedepends="e2fsprogs-dev e2fsprogs-extra"
+subpackages="$pkgname-doc"
+source="e2fsimage-$pkgver.tar.gz::https://github.com/Ledest/e2fsimage/archive/$pkgver.tar.gz"
+builddir="$srcdir/e2fsimage-$pkgver"
+
+build() {
+ cd "$builddir"
+ prefix=/usr mandir=/usr/share/man ./configure
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./src/e2fsimage -f test.img -d ./src
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b6bf97ae35af7c48063f7a6dc19af80fec4bdfcd4d9b6064168b5e5a37ead57b3a01772f659f5004d6d5f1217cccba6a019e1974f87503fcaf526a15d6187ed7 e2fsimage-0.2.3.tar.gz"