aboutsummaryrefslogtreecommitdiffstats
path: root/testing/efitools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-10-17 13:58:09 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-10-17 13:58:09 +0300
commitf103544c092c468df9db1eaf6814c60e768456d4 (patch)
tree40385cf2d651522cf40706e0bb33a5cdc1a8ee82 /testing/efitools
parentbaf678f97803f64ffd10dbcdb6cb65a611ff9543 (diff)
downloadaports-f103544c092c468df9db1eaf6814c60e768456d4.tar.bz2
aports-f103544c092c468df9db1eaf6814c60e768456d4.tar.xz
testing/efitools: new aport
EFI tools https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git
Diffstat (limited to 'testing/efitools')
-rw-r--r--testing/efitools/001-datatypes.patch11
-rw-r--r--testing/efitools/APKBUILD31
2 files changed, 42 insertions, 0 deletions
diff --git a/testing/efitools/001-datatypes.patch b/testing/efitools/001-datatypes.patch
new file mode 100644
index 0000000000..a55da69169
--- /dev/null
+++ b/testing/efitools/001-datatypes.patch
@@ -0,0 +1,11 @@
+--- a/lib/asn1/oid.h 2017-03-24 16:04:44.603350102 +0200
++++ b/lib/asn1/oid.h 2017-03-24 19:58:30.876866547 +0200
+@@ -8,6 +8,8 @@
+ #ifndef OID_H_
+ #define OID_H_
+
++#include <sys/types.h>
++
+ typedef struct {
+ u_char octet;
+ u_int next;
diff --git a/testing/efitools/APKBUILD b/testing/efitools/APKBUILD
new file mode 100644
index 0000000000..1e6ddd4cf8
--- /dev/null
+++ b/testing/efitools/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Tero Hilpinen <tero.hilpinen@symbio.com>
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+
+pkgname=efitools
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="EFI tools"
+url="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git"
+arch="x86_64"
+license="GPL"
+depends=""
+makedepends="autoconf automake binutils-dev gnu-efi-dev libressl-dev perl-file-slurp help2man sbsigntool"
+install=""
+subpackages="$pkgname-doc"
+source="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz
+ 001-datatypes.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d4a04400b89a83184cef3e82a98c666240a4a2737156e9a46a563f49586af53c66f7d54eb9e9602434b5d060faf285c5105fb74e6073974ba68891ddbd918557 efitools-1.7.0.tar.gz
+cd72161a99b26472909a8da834c08a1f88b54d35291a6646562b03a6616fa5fb61e49d4fb3c780861689d23823c101709890dd245dd8aa9f51dca40ac1b2d369 001-datatypes.patch"