aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fasd
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-04 22:58:48 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-04 22:59:06 +0200
commit8a97cde4de891f1d4455412151f5469396ecce68 (patch)
treeaac087a0d48df88156920ae67d2bb03274c14802 /testing/fasd
parent59fc81812fbbc7595934f8c0db9eb242c6033bd0 (diff)
downloadaports-8a97cde4de891f1d4455412151f5469396ecce68.tar.bz2
aports-8a97cde4de891f1d4455412151f5469396ecce68.tar.xz
testing/fasd: new aport
Command-line productivity booster, offers quick access to files and directories https://github.com/clvv/fasd
Diffstat (limited to 'testing/fasd')
-rw-r--r--testing/fasd/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/fasd/APKBUILD b/testing/fasd/APKBUILD
new file mode 100644
index 0000000000..470c8dd7bf
--- /dev/null
+++ b/testing/fasd/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=fasd
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Command-line productivity booster, offers quick access to files and directories"
+url="https://github.com/clvv/fasd"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/clvv/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ sed -i 's|^#!/usr/bin/env sh|#!/bin/sh|' fasd
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+sha512sums="0f68fe5501379738894ba8fd0495a137398b6d0196aac040028c45ae486ec040ea7c2e4521f6ad43b5d22f48d048dbc734716f5e7400e3b2b3184f820e969a19 fasd-1.0.1.tar.gz"