aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorOrson Teodoro <orsonteodoro@hotmail.com>2018-01-23 16:02:37 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-25 15:56:25 +0000
commit725ef5e49abb7c32542fc41c4b1512b65f1ee059 (patch)
treea94d9afd8d2c7df2bde6ed4482075ac0154c2b0d /testing/firefox
parent429d18eb7623976822a202339501c1032fb4d7be (diff)
downloadaports-725ef5e49abb7c32542fc41c4b1512b65f1ee059.tar.bz2
aports-725ef5e49abb7c32542fc41c4b1512b65f1ee059.tar.xz
testing/firefox: add H.264 support with ffmpeg for YouTube live streams and some Internet radio stations
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index 7b90b18d16..96593a3924 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -20,6 +20,7 @@ makedepends="
cargo
clang-dev
dbus-glib-dev
+ ffmpeg-dev
gconf-dev
gtk+2.0-dev
gtk+3.0-dev
@@ -92,6 +93,12 @@ prepare() {
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
# https://bugzilla.mozilla.org/show_bug.cgi?id=1341234
echo "ac_add_options BINDGEN_CFLAGS='-I/usr/include/nspr -I/usr/include/pixman-1'" >>.mozconfig
+
+ for f in $(grep -l -r -e "use std::ascii::AsciiExt;" "${srcdir}/firefox-$pkgver/servo/components/style/"); do
+ msg "Patching $f"
+ sed -i -e 's|#[allow(unused_imports)] use std::ascii::AsciiExt;|use std::ascii::AsciiExt;|g' \
+ -e 's|use std::ascii::AsciiExt;|#[allow(unused_imports)] use std::ascii::AsciiExt;|g' "${f}" || return 1
+ done
}
build() {
@@ -130,6 +137,7 @@ build() {
--enable-system-ffi \
--enable-system-hunspell \
--enable-system-sqlite \
+ --enable-ffmpeg \
\
--with-pthreads \
--with-system-bz2 \