aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorkhanku <khanku@localhost>2017-05-27 22:40:07 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 13:00:35 +0000
commit8bd4ddd35351eda6ea89e460312291ebd0f43fb6 (patch)
tree51b3c715cee386e1fbd1000a2240b462d5ca2ce7 /testing/firefox
parent883cd12b549a992175f1f7f51d2371e15d13b66d (diff)
downloadaports-8bd4ddd35351eda6ea89e460312291ebd0f43fb6.tar.bz2
aports-8bd4ddd35351eda6ea89e460312291ebd0f43fb6.tar.xz
testing/firefox: update to 53.0.3
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD38
-rw-r--r--testing/firefox/fix-bug-1261392.patch25
-rw-r--r--testing/firefox/fix-bug-1338655.patch29
-rw-r--r--testing/firefox/fix-rust-target.patch16
4 files changed, 87 insertions, 21 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index 4fcdef400a..57aec92893 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=firefox
-pkgver=52.0.2
+pkgver=53.0.3
_pkgver=$pkgver
_xulver=$pkgver
pkgrel=0
@@ -10,9 +10,13 @@ url="http://www.firefox.com"
arch="all !aarch64"
license="GPL LGPL MPL"
depends=""
-depends_dev="
+makedepends="
alsa-lib-dev
+ autoconf2.13
+ automake
+ bsd-compat-headers
bzip2-dev
+ cargo
dbus-glib-dev
gconf-dev
gtk+2.0-dev
@@ -25,6 +29,7 @@ depends_dev="
libnotify-dev
libogg-dev
libtheora-dev
+ libtool
libvorbis-dev
libvpx-dev
libxt-dev
@@ -32,25 +37,18 @@ depends_dev="
mesa-dev
nspr-dev
nss-dev
- sqlite-dev
- startup-notification-dev
- wireless-tools-dev
- "
-makedepends="$depends_dev
- autoconf2.13
- automake
- bsd-compat-headers
- libtool
nss-static
paxmark
python2
+ sqlite-dev
sed
+ startup-notification-dev
+ wireless-tools-dev
yasm
zip
"
install=""
-subpackages="$pkgname-dev"
source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
stab.h
@@ -68,13 +66,15 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
fix-arm-version-detect.patch
mozilla-build-arm.patch
disable-moz-stackwalk.patch
+ fix-rust-target.patch
+ fix-bug-1338655.patch
+ fix-bug-1261392.patch
firefox.desktop
firefox-safe.desktop"
builddir="${srcdir}/firefox-$pkgver"/objdir
_mozappdir=/usr/lib/firefox-$pkgver
-_mozappdirdev=/usr/lib/firefox-devel-$pkgver
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
@@ -218,14 +218,7 @@ __EOF__
rm -f "$pkgdir"/${_mozappdirdev}/sdk/lib/libxul.so
}
-dev() {
- mkdir -p "$subpkgdir"/${_mozappdirdev%/*}
- mv "$pkgdir"/${_mozappdirdev} "$subpkgdir"/${_mozappdirdev%/*} \
- || return 1
- default_dev
-}
-
-sha512sums="15668625d212acf874b560d0adf738faf3e0df532c549ab94e1d91944542e13bf16265f08fca1eded42820f9b7ad3f0ff70a8b5bc9adde0a79d11e022bb1158e firefox-52.0.2.source.tar.xz
+sha512sums="cef5de1e9d6ddf6509a80cd30169fdce701b2fed022979ba5931ccea7b8f77cb644b01984dae028d350e32321cfe2eefc0236c0731bf5a2be12a994fc3fc1118 firefox-53.0.3.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
7e123144bc2b1efed149dfb41b255c447d43ea93a63ebe114d01945e6a6d69edc2f2a3c36980a93279106c1842355851b8b6c1d96679ee6be7b9b30513e0b1a8 0002-Use-C99-math-isfinite.patch
09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
@@ -240,5 +233,8 @@ ed0d344c66fc8e1cc83a11e9858b32c42e841cbeedd9eb9438811e9fcc3593dc824a8336d00058d5
015e1ff6dbf920033982b5df95d869a0b7bf56c6964e45e50649ddf46d1ce09563458e45240c3ecb92808662b1300b67507f7af272ba184835d91068a9e7d5b0 fix-arm-version-detect.patch
e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb18b9e3138273ea8ddcfdcb1084fdcaa922a1e5b30146a3b18 mozilla-build-arm.patch
4797d2d89ac63a57abb826b8ea9f751314ce66946194033deb9d78c2ff377b88106fd2c7bc5034dc13ad03dd5085b1893c3ccae1a9e63fde35655bb0921f7188 disable-moz-stackwalk.patch
+09d73d9058fbdb0992758e3377d8d4ea0b01cd291bdfbb918ec8b7b1ffb118bba3ff71efaca6107a0510fad295dd8de3102d8933b80d3a3546d7423e707e37b2 fix-rust-target.patch
+5dc24f9725514dd2a00c132e6ee0a38cc417ce5c8f280011daae70d1224362c625f5a02b72d44bb9138191e9e3d512855edd59db531982fab4968e923ae7edf6 fix-bug-1338655.patch
+a50b412edf9573a0bd04a43578b1c927967a616b73a5995eefb15bfa78fd2bd14e36ec05315a0703f6370ecd524e6bcb012e7285beb1245e9add9b8553acb79e fix-bug-1261392.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/testing/firefox/fix-bug-1261392.patch b/testing/firefox/fix-bug-1261392.patch
new file mode 100644
index 0000000000..1f7a36af3b
--- /dev/null
+++ b/testing/firefox/fix-bug-1261392.patch
@@ -0,0 +1,25 @@
+--- a/tools/profiler/core/platform.h 2017-05-27 11:44:06.733119794 +0000
++++ b/tools/profiler/core/platform.h 2017-05-27 11:46:16.004253520 +0000
+@@ -54,10 +54,11 @@
+ #include <vector>
+ #include "StackTop.h"
+
+-// We need a definition of gettid(), but glibc doesn't provide a
+-// wrapper for it.
+-#if defined(__GLIBC__)
++// We need a definition of gettid(), but Linux libc implementations don't
++// provide a wrapper for it (except for Bionic)
++#if defined(__linux__)
+ #include <unistd.h>
++#if !defined(__BIONIC__)
+ #include <sys/syscall.h>
+ static inline pid_t gettid()
+ {
+@@ -71,6 +72,7 @@
+ return (pid_t) syscall(SYS_thread_selfid);
+ }
+ #endif
++#endif
+
+ #ifdef XP_WIN
+ #include <windows.h>
diff --git a/testing/firefox/fix-bug-1338655.patch b/testing/firefox/fix-bug-1338655.patch
new file mode 100644
index 0000000000..a6259ebef4
--- /dev/null
+++ b/testing/firefox/fix-bug-1338655.patch
@@ -0,0 +1,29 @@
+--- a/media/libstagefright/binding/mp4parse-cargo.patch
++++ b/media/libstagefright/binding/mp4parse-cargo.patch
+@@ -27,12 +27,13 @@ diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libst
+ index aeeebc65..5c0836a 100644
+ --- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+ +++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+-@@ -18,18 +18,10 @@ exclude = [
++@@ -18,18 +18,12 @@ exclude = [
+ "*.mp4",
+ ]
+
+ -build = "build.rs"
+--
+++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
+--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
++++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+@@ -18,6 +18,8 @@ exclude = [
+ "*.mp4",
+ ]
+
++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
diff --git a/testing/firefox/fix-rust-target.patch b/testing/firefox/fix-rust-target.patch
new file mode 100644
index 0000000000..c1b48d54bc
--- /dev/null
+++ b/testing/firefox/fix-rust-target.patch
@@ -0,0 +1,16 @@
+--- a/build/moz.configure/rust.configure
++++ b/build/moz.configure/rust.configure
+@@ -127,10 +127,10 @@
+ ('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
+ # Linux
+ ('aarch64', 'Linux'): 'aarch64-unknown-linux-gnu',
+- ('arm', 'Linux'): 'armv7-unknown-linux-gnueabihf',
++ ('arm', 'Linux'): 'armv6-alpine-linux-musleabihf',
+ ('sparc64', 'Linux'): 'sparc64-unknown-linux-gnu',
+- ('x86', 'Linux'): 'i686-unknown-linux-gnu',
+- ('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
++ ('x86', 'Linux'): 'i686-alpine-linux-musl',
++ ('x86_64', 'Linux'): 'x86_64-alpine-linux-musl',
+ # OS X
+ ('x86', 'OSX'): 'i686-apple-darwin',
+ ('x86_64', 'OSX'): 'x86_64-apple-darwin',