aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-02-01 17:44:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-01 20:13:51 +0000
commitaeab50c64318f49054e86eb7692f1c2925f904ce (patch)
treeabf977e3b5f86b82b664fd7b43e1bbc6e3d00cdb /testing/firefox
parentfb136adc438f327fb5171d22ed7620feeef0a013 (diff)
downloadaports-aeab50c64318f49054e86eb7692f1c2925f904ce.tar.bz2
aports-aeab50c64318f49054e86eb7692f1c2925f904ce.tar.xz
testing/firefox: fix alsa sound
fixes #8430
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD4
-rw-r--r--testing/firefox/fix-sandbox-alsa.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index ae73c1963b..7737df1065 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=58.0.1
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="http://www.firefox.com"
# limited by rust and cargo
@@ -71,6 +71,7 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
fix-rust-target.patch
fix-bug-1261392.patch
servo-allow-unused-imports.patch
+ fix-sandbox-alsa.patch
firefox.desktop
firefox-safe.desktop"
@@ -232,5 +233,6 @@ e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb1
42cc44fda4b05259b38f055d6f51461746aa89a474cedc5e92fb9d20879da0d12b1b515b273a549e7302cda9c7eddde20d5fdba09853e5c658784ad6d0b20078 fix-rust-target.patch
a50b412edf9573a0bd04a43578b1c927967a616b73a5995eefb15bfa78fd2bd14e36ec05315a0703f6370ecd524e6bcb012e7285beb1245e9add9b8553acb79e fix-bug-1261392.patch
7fcdda2028edbcf099ea8b88811d08f298740f86ec1ebef2c81aaa62f63a73f1a710b3756f7b6a42bdbc2b147e74d2f2e74a65c96604205029f7d1d8250954da servo-allow-unused-imports.patch
+c467d9f69c864b53840424341b7790a9757701189137fbcab8d5e2cfc039ae870090adde070abe45d7d9a19ef11a69b2dd3064b6a13f5d1af8964b1cdf440fed fix-sandbox-alsa.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/testing/firefox/fix-sandbox-alsa.patch b/testing/firefox/fix-sandbox-alsa.patch
new file mode 100644
index 0000000000..364e73318b
--- /dev/null
+++ b/testing/firefox/fix-sandbox-alsa.patch
@@ -0,0 +1,12 @@
+--- ./security/sandbox/linux/moz.build.orig
++++ ./security/sandbox/linux/moz.build
+@@ -77,6 +77,9 @@
+ 'SandboxOpenedFiles.cpp',
+ ]
+
++if CONFIG['MOZ_ALSA']:
++ DEFINES['MOZ_ALSA'] = True
++
+ # This copy of SafeSPrintf doesn't need to avoid the Chromium logging
+ # dependency like the one in libxul does, but this way the behavior is
+ # consistent. See also the comment in SandboxLogging.h.