aboutsummaryrefslogtreecommitdiffstats
path: root/testing/flightgear
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-11-03 07:18:24 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-11-03 07:18:59 +0000
commit7ab33742d2692c2560cd4e66b581badbe8414a67 (patch)
treeb3cb0989db73940b0f032dc7518d8015f690f4bf /testing/flightgear
parentcba6d9009f3048e5bf9edffa2f38ecc8340bbbcd (diff)
downloadaports-7ab33742d2692c2560cd4e66b581badbe8414a67.tar.bz2
aports-7ab33742d2692c2560cd4e66b581badbe8414a67.tar.xz
testing/flightgear: upgrade to 2017.3.1
Diffstat (limited to 'testing/flightgear')
-rw-r--r--testing/flightgear/APKBUILD13
-rw-r--r--testing/flightgear/musl-fixes.patch129
2 files changed, 70 insertions, 72 deletions
diff --git a/testing/flightgear/APKBUILD b/testing/flightgear/APKBUILD
index 54990812d6..5f87e331ad 100644
--- a/testing/flightgear/APKBUILD
+++ b/testing/flightgear/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
pkgname=flightgear
-pkgver=2017.1.3
-pkgrel=1
+pkgver=2017.3.1
+pkgrel=0
pkgdesc="Sophisticated flight simulator"
url="http://flightgear.org"
arch="all"
license="GPL"
makedepends="$depends_dev boost-dev cmake curl-dev dbus-dev eudev-dev
- freeglut-dev libx11-dev libxi-dev libxmu-dev mesa-dev openal-soft-dev
- openscenegraph-dev plib qt5-qtbase-dev simgear zlib-dev"
+ freeglut-dev glew-dev libx11-dev libxi-dev libxmu-dev mesa-dev
+ openal-soft-dev openscenegraph-dev plib qt5-qtbase-dev
+ qt5-qtdeclarative-dev simgear zlib-dev"
install=
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/release-${pkgver%.[1-9]*}/$pkgname-$pkgver.tar.bz2
@@ -39,6 +40,6 @@ package() {
# install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="93aa27a976bcdd79c76eb9751ba90a79a6146d8f3961c3bdf1db136a99cb9a0ab644c7409a26267181be0476fa455bf739b78cb7028e3e12d5509f96a1d3f303 flightgear-2017.1.3.tar.bz2
-d7c4ab6020412c6853b73ed44ed25f3ee8dae0fc074a9f7c1698e2b48161cbb2aef02ebb96a2e4ebafa30886577b3cbf8001ade1761bd0c396acb48cb9f189ab musl-fixes.patch
+sha512sums="e91268b4fc6a5b04761cf64e003e9962e5a66a91c0f089a1de220ef7cc438250dbd93ed99773c09f19255604c4cc5a0b65b80fe19e663fa0eae8107374527b4b flightgear-2017.3.1.tar.bz2
+3350de9e465dc4f865d2a94d96b2f79b4c98c994fc4713cfa296c20ed12129f310779171b89639f69d1e4f5f0103fca6cc01df5a9e25d77f93a0b4e76f6b973a musl-fixes.patch
49d359d213870ad71a3403e93951574b334d8281fbe9553fe259d65e1b0a8659c127cde11ffdf2ba3351c2af2dabe60657dab6dab3ff0c9fecad4a398fd6f2eb fix-link_with_x11.patch"
diff --git a/testing/flightgear/musl-fixes.patch b/testing/flightgear/musl-fixes.patch
index 00ef78d3b7..c72ea90c78 100644
--- a/testing/flightgear/musl-fixes.patch
+++ b/testing/flightgear/musl-fixes.patch
@@ -1,51 +1,10 @@
-diff --git a/3rdparty/hts_engine_API/lib/HTS_misc.c b/3rdparty/hts_engine_API/lib/HTS_misc.c
-index b0d112d..6de47ee 100644
---- a/3rdparty/hts_engine_API/lib/HTS_misc.c
-+++ b/3rdparty/hts_engine_API/lib/HTS_misc.c
-@@ -247,8 +247,10 @@ size_t HTS_ftell(HTS_File * fp)
- fgetpos((FILE *) fp->pointer, &pos);
- #if defined(_WIN32) || defined(__CYGWIN__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__ANDROID__)
- return (size_t) pos;
--#else
-+#elif defined(__GLIBC__)
- return (size_t) pos.__pos;
-+#else
-+ return (size_t) ftell(fp->pointer);
- #endif /* _WIN32 || __CYGWIN__ || __APPLE__ || __ANDROID__ */
- } else if (fp->type == HTS_DATA) {
- HTS_Data *d = (HTS_Data *) fp->pointer;
-diff --git a/3rdparty/iaxclient/lib/libiax2/src/iax.c b/3rdparty/iaxclient/lib/libiax2/src/iax.c
-index 0bfd2e4..39eea99 100644
---- a/3rdparty/iaxclient/lib/libiax2/src/iax.c
-+++ b/3rdparty/iaxclient/lib/libiax2/src/iax.c
-@@ -75,7 +75,7 @@
- // FlightGear: Modified to include FreeBSD
- #if !defined(MACOSX) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
- #include <malloc.h>
--#if !defined(SOLARIS)
-+#if !defined(SOLARIS) && defined(__GLIBC__)
- #include <error.h>
- #endif
- #endif
-diff --git a/src/FDM/JSBSim/JSBSim.cpp b/src/FDM/JSBSim/JSBSim.cpp
-index 87b5e6e..ea39ca6 100644
---- a/src/FDM/JSBSim/JSBSim.cpp
-+++ b/src/FDM/JSBSim/JSBSim.cpp
-@@ -287,7 +287,7 @@ int main(int argc, char* argv[])
- _clearfp();
- _controlfp(_controlfp(0, 0) & ~(_EM_INVALID | _EM_ZERODIVIDE | _EM_OVERFLOW),
- _MCW_EM);
--#elif defined(__GNUC__) && !defined(sgi) && !defined(__APPLE__)
-+#elif defined(__GLIBC__)
- feenableexcept(FE_DIVBYZERO | FE_INVALID);
- #endif
-
-diff --git a/src/Main/bootstrap.cxx b/src/Main/bootstrap.cxx
-index 550d028..db369ea 100644
---- a/src/Main/bootstrap.cxx
-+++ b/src/Main/bootstrap.cxx
-@@ -93,12 +93,16 @@ static void handleFPE(int);
- static void
+Simply disabling the code which enables floating point exceptions
+is probably wrong, but I don't have a replacement for the
+non-posix functions fegetexcept(3) and feenableexcept(3).
+
+--- a/src/Main/bootstrap.cxx 2015-02-18 21:10:05.000000000 +0100
++++ b/src/Main/bootstrap.cxx 2015-11-01 01:25:56.665212195 +0100
+@@ -96,8 +96,12 @@
initFPE (bool fpeAbort)
{
+#if defined(__GLIBC__)
@@ -58,29 +17,67 @@ index 550d028..db369ea 100644
+#else
+ signal(SIGFPE, handleFPE);
+#endif
- }
-
- static void handleFPE(int)
-@@ -137,7 +141,7 @@ int WINAPI WinMain(HINSTANCE hInstance, HINSTANCE hPrevInstance,
+There is no <error.h> in musl libc, thus enable the
+include only if __GLIB__ is defined.
+
+--- a/3rdparty/iaxclient/lib/libiax2/src/iax.c 2015-02-18 21:10:05.000000000 +0100
++++ b/3rdparty/iaxclient/lib/libiax2/src/iax.c 2015-10-31 17:14:55.477461723 +0100
+@@ -75,7 +75,7 @@
+ // FlightGear: Modified to include FreeBSD
+ #if !defined(MACOSX) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
+ #include <malloc.h>
+-#if !defined(SOLARIS)
++#if !defined(SOLARIS) && defined(__GLIBC__)
+ #include <error.h>
+ #endif
+ #endif
+--- a/src/Main/bootstrap.cxx 2017-03-17 09:52:07.474706542 +0100
++++ b/src/Main/bootstrap.cxx 2017-03-17 09:53:40.361793507 +0100
+@@ -141,7 +141,7 @@
}
#endif
-#if defined(__GNUC__)
-+#if defined(__GLIBC__)
++#if defined(__GNUC__) && defined(__GLIBC__)
#include <execinfo.h>
#include <cxxabi.h>
void segfault_handler(int signo) {
-@@ -182,7 +186,12 @@ void segfault_handler(int signo) {
- free(fname);
- free(list);
- }
--
-+ exit(1);
-+}
-+#else
-+/* musl doesn't have execinfo */
-+void segfault_handler(int signo) {
-+ fprintf(stderr, "Error: caught signal %d:\n", signo);
- exit(1);
- }
+@@ -244,8 +244,10 @@
+
+ signal(SIGPIPE, SIG_IGN);
+ # ifndef NDEBUG
++# ifdef __GLIBC__
+ signal(SIGSEGV, segfault_handler);
+ # endif
++# endif
#endif
+
+ _bootstrap_OSInit = 0;
+--- a/src/FDM/JSBSim/JSBSim.cpp 2017-03-01 21:06:31.000000000 +0100
++++ b/src/FDM/JSBSim/JSBSim.cpp 2017-03-17 09:49:13.115544107 +0100
+@@ -287,7 +287,7 @@
+ _clearfp();
+ _controlfp(_controlfp(0, 0) & ~(_EM_INVALID | _EM_ZERODIVIDE | _EM_OVERFLOW),
+ _MCW_EM);
+-#elif defined(__GNUC__) && !defined(sgi) && !defined(__APPLE__)
++#elif defined(__GNUC__) && !defined(sgi) && !defined(__APPLE__) && defined(__GLIBC__)
+ feenableexcept(FE_DIVBYZERO | FE_INVALID);
+ #endif
+
+For musl libc return the file position using
+ftell(3) because fpos_t is opaque.
+
+--- a/3rdparty/hts_engine_API/lib/HTS_misc.c 2015-02-18 21:10:05.000000000 +0100
++++ b/3rdparty/hts_engine_API/lib/HTS_misc.c 2015-10-31 17:33:53.946349145 +0100
+@@ -247,8 +247,10 @@
+ fgetpos((FILE *) fp->pointer, &pos);
+ #if defined(_WIN32) || defined(__CYGWIN__) || defined(__APPLE__) || defined(__ANDROID__) || defined(__FreeBSD__)
+ return (size_t) pos;
+-#else
++#elif defined(__GLIBC__)
+ return (size_t) pos.__pos;
++#else
++ return (size_t) ftell(fp->pointer);
+ #endif /* _WIN32 || __CYGWIN__ || __APPLE__ || __ANDROID__ */
+ }
+ HTS_error(0, "HTS_ftell: Unknown file type.\n");