aboutsummaryrefslogtreecommitdiffstats
path: root/testing/flightgear
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-04 13:50:07 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-04 13:50:07 +0000
commite1425464956676b487a8e958d16756dd6a7c71fa (patch)
tree1482976c4d69840438a315daa3ea9ed85fad311d /testing/flightgear
parente8f9e99de957869ffe913ce7f22ac2655849290a (diff)
downloadaports-e1425464956676b487a8e958d16756dd6a7c71fa.tar.bz2
aports-e1425464956676b487a8e958d16756dd6a7c71fa.tar.xz
testing/flightgear: don't build on ppc64le due to osg not avail
Diffstat (limited to 'testing/flightgear')
-rw-r--r--testing/flightgear/APKBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/testing/flightgear/APKBUILD b/testing/flightgear/APKBUILD
index 03a3784b7d..3bc16d5c00 100644
--- a/testing/flightgear/APKBUILD
+++ b/testing/flightgear/APKBUILD
@@ -1,32 +1,23 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
pkgname=flightgear
-_ver=2017.1
-_revision=3
-pkgver=${_ver}.$_revision
-pkgrel=0
+pkgver=2017.1.3
+pkgrel=1
pkgdesc="Sophisticated flight simulator"
url="http://flightgear.org"
-arch="all"
+arch="all !ppc64le" #openscenegraph not avail on exluded arches
license="GPL"
-depends=
-depends_dev=
makedepends="$depends_dev boost-dev cmake curl-dev dbus-dev eudev-dev
freeglut-dev libx11-dev libxi-dev libxmu-dev mesa-dev openal-soft-dev
openscenegraph-dev plib qt5-qtbase-dev simgear zlib-dev"
install=
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/project/$pkgname/release-$_ver/$pkgname-$pkgver.tar.bz2
+source="http://downloads.sourceforge.net/project/$pkgname/release-${pkgver%.[1-9]*}/$pkgname-$pkgver.tar.bz2
musl-fixes.patch
fix-link_with_x11.patch
"
builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$builddir"
- default_prepare || return 1
-}
-
build() {
cd "$builddir"
mkdir _build.tmp && cd _build.tmp