aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fstrm/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-07-16 16:04:46 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-28 14:29:11 +0000
commit5d768aafdf827c7aa3efb612653f847728d9e7f0 (patch)
tree8a2bcfab0509c3b403c7f24cbe8c305b74b36059 /testing/fstrm/APKBUILD
parentbddb056854c3044880cc7993156f1957689e2d41 (diff)
downloadaports-5d768aafdf827c7aa3efb612653f847728d9e7f0.tar.bz2
aports-5d768aafdf827c7aa3efb612653f847728d9e7f0.tar.xz
testing/fstrm: new aport
https://github.com/farsightsec/fstrm Frame Streams implementation in C Squashed commit of the following: commit 47ab4b663109c0bc75699cf06197975cec7dfaa5 Author: tcely <tcely@users.noreply.github.com> Date: Wed Jun 13 23:41:06 2018 -0400 testing/fstrm: upgrade to 0.4.0 commit 5e041f513a81d1d24780747743e8710b3a32f022 Author: tcely <tcely@users.noreply.github.com> Date: Mon Apr 9 15:11:33 2018 -0400 testing/fstrm: add contributor commit d7df45cacafea1de4a07a215e3d4ffc216f2ecd9 Author: tcely <tcely@users.noreply.github.com> Date: Sun Apr 8 11:05:49 2018 -0400 testing/fstrm: new aport https://github.com/farsightsec/fstrm Frame Streams implementation in C
Diffstat (limited to 'testing/fstrm/APKBUILD')
-rw-r--r--testing/fstrm/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/fstrm/APKBUILD b/testing/fstrm/APKBUILD
new file mode 100644
index 0000000000..cce7355bf4
--- /dev/null
+++ b/testing/fstrm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: tcely <tcely@users.noreply.github.com>
+# Maintainer:
+pkgname="fstrm"
+pkgver="0.4.0"
+pkgrel=0
+pkgdesc="Frame Streams implementation in C"
+url="https://github.com/farsightsec/fstrm"
+arch="all"
+license="Apache-2.0"
+depends=""
+depends_dev="libevent-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://dl.farsightsecurity.com/dist/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
+}
+
+package() {
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha256sums="b20564cb2ebc7783a8383fbef5bcef5726f94baf48b83843553c9e1030b738ef fstrm-0.4.0.tar.gz"