aboutsummaryrefslogtreecommitdiffstats
path: root/testing/geos
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-31 23:52:37 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-31 23:52:37 +0100
commit00e4a1eddb1eca82a5b0e26366d0b2453b0428ea (patch)
treef81f5b5264d21c98ead195a38b708da270313c49 /testing/geos
parent378408ed0f46fc3652750346f31e0604b1657c0e (diff)
downloadaports-00e4a1eddb1eca82a5b0e26366d0b2453b0428ea.tar.bz2
aports-00e4a1eddb1eca82a5b0e26366d0b2453b0428ea.tar.xz
testing/geos: clean-up abuild and move check to check()
Diffstat (limited to 'testing/geos')
-rw-r--r--testing/geos/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/testing/geos/APKBUILD b/testing/geos/APKBUILD
index 4714384aab..1158c146d4 100644
--- a/testing/geos/APKBUILD
+++ b/testing/geos/APKBUILD
@@ -7,17 +7,14 @@ pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
url="http://trac.osgeo.org/geos/"
arch="x86 x86_64"
license="LGPL-2.1"
-depends=""
-depends_dev=""
-makedepends="swig python2-dev $depends_dev"
-install=""
+makedepends="swig python2-dev"
subpackages="py-$pkgname:py $pkgname-dev"
source="http://download.osgeo.org/geos/geos-$pkgver.tar.bz2"
-
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,30 +22,33 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --enable-python \
- || return 1
+ --enable-python
# --enable-ruby produces a gem which crashes, and which seems to
# mostly ignored in favor of the rgeo and ffi-geos modules, anyway.
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
- # This is a complex library that does lots of complicated numeric
- # stuff, and the unit tests are fast, so let's run them just to be
- # safe.
- make check || return 1
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+
+ make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
py() {
- cd "$builddir"
pkgdesc="$pkgname Python bindings"
+
+ cd "$builddir"
install -d "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
+
sha512sums="515d8700b8a28282678e481faee355e3a43d7b70160472a63335b8d7225d9ba10437be782378f18f31a15288118126d411a2d862f01ce35d27c96f6bc0a73016 geos-3.6.2.tar.bz2"