aboutsummaryrefslogtreecommitdiffstats
path: root/testing/glog
diff options
context:
space:
mode:
authorDavid Huffman <storedbox@outlook.com>2016-01-07 15:24:08 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-08 13:26:15 +0000
commite4a8ec19de5a41d11b1995e184a1fbfa5c92cf3a (patch)
tree2dfc7fadd5207bef3ae9223b7a4f926ea5d319da /testing/glog
parenta42b037abb9a6b56934304964ac5a607c7d52237 (diff)
downloadaports-e4a8ec19de5a41d11b1995e184a1fbfa5c92cf3a.tar.bz2
aports-e4a8ec19de5a41d11b1995e184a1fbfa5c92cf3a.tar.xz
testing/glog: new aport
https://github.com/google/glog C++ implementation of the Google logging module
Diffstat (limited to 'testing/glog')
-rw-r--r--testing/glog/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/glog/APKBUILD b/testing/glog/APKBUILD
new file mode 100644
index 0000000000..3db268ddc5
--- /dev/null
+++ b/testing/glog/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: David Huffman <storedbox@outlook.com>
+# Maintainer: David Huffman <storedbox@outlook.com>
+pkgname=glog
+pkgver=0.3.4
+pkgrel=0
+pkgdesc="C++ implementation of the Google logging module"
+url="https://github.com/google/glog"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/google/glog/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --disable-dependency-tracking --disable-rtti --with-pic || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="df92e05c9d02504fb96674bc776a41cb glog-0.3.4.tar.gz"
+sha256sums="ce99d58dce74458f7656a68935d7a0c048fa7b4626566a71b7f4e545920ceb10 glog-0.3.4.tar.gz"
+sha512sums="139525b546a9eccacc9bebf7cc3053ba52229e9488485ad45344c3d3134ca819d3b571250c0e3a6d84097009c8be89b0f4fa16ef5ec838ffcc237ae11c3a034c glog-0.3.4.tar.gz"