aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-session
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-07 05:48:32 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-07 05:49:20 +0000
commit0f1ad5e2402fc1e2ae69f8cfc01386e836297714 (patch)
tree67980acc31a19350b8c3fcfdb00a6163e284fbf4 /testing/gnome-session
parent1b11055c54a9100f6c62d38cbca4fa2d3f74e1b1 (diff)
downloadaports-0f1ad5e2402fc1e2ae69f8cfc01386e836297714.tar.bz2
aports-0f1ad5e2402fc1e2ae69f8cfc01386e836297714.tar.xz
testing/gnome-session: new aport
Diffstat (limited to 'testing/gnome-session')
-rw-r--r--testing/gnome-session/APKBUILD38
-rw-r--r--testing/gnome-session/fail-whale-dialog.patch35
-rw-r--r--testing/gnome-session/no-rpmatch.patch15
3 files changed, 88 insertions, 0 deletions
diff --git a/testing/gnome-session/APKBUILD b/testing/gnome-session/APKBUILD
new file mode 100644
index 0000000000..63b421e00c
--- /dev/null
+++ b/testing/gnome-session/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gnome-session
+pkgver=3.24.1
+pkgrel=0
+pkgdesc="GNOME session manager"
+url="http://www.gnome.org/"
+arch="all"
+license="GPL"
+depends="gnome-shell"
+depends_dev=""
+makedepends="gnome-settings-daemon-dev libsm-dev itstool libxslt libxml2-utils"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-session/${pkgver%.*}/gnome-session-$pkgver.tar.xz
+ fail-whale-dialog.patch
+ no-rpmatch.patch"
+builddir="$srcdir/gnome-session-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="507f9f1cddab37f1b66c72291e1885397f7e8b6bfb7c365f6f1ff827649a71380706fe0e3a8c6e74c3c159349a0eea0aabe3d5c7bbae5b29aeb2d49ae715affb gnome-session-3.24.1.tar.xz
+0a5dd181c060a8d403b26b3d3b647b6cc7c519b487a05a2f11693fdbb9f61257e4e433c989c835cf1210bc199a92e9d5418b7de9a2a248b595b679f3c1c2b9b5 fail-whale-dialog.patch
+0d6057cc47f3494050cf02f55b887ae0fea2b405fe3585b412f91c79dafaab77a4d3da2d77fa65bd43a7a9a77b83c11e78f68af659378f3f62f857ca1a86c6de no-rpmatch.patch"
diff --git a/testing/gnome-session/fail-whale-dialog.patch b/testing/gnome-session/fail-whale-dialog.patch
new file mode 100644
index 0000000000..e7a54f57f0
--- /dev/null
+++ b/testing/gnome-session/fail-whale-dialog.patch
@@ -0,0 +1,35 @@
+$OpenBSD: patch-gnome-session_gsm-fail-whale-dialog_c,v 1.1 2017/05/30 18:14:03 ajacoutot Exp $
+
+https://bugzilla.gnome.org/show_bug.cgi?id=775463
+
+Index: gnome-session/gsm-fail-whale-dialog.c
+--- a/gnome-session/gsm-fail-whale-dialog.c.orig
++++ b/gnome-session/gsm-fail-whale-dialog.c
+@@ -371,13 +371,20 @@ int main (int argc, char *argv[])
+ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
+ textdomain (GETTEXT_PACKAGE);
+
+- gtk_init_with_args (&argc, &argv, " - fail whale",
+- entries, GETTEXT_PACKAGE,
+- &error);
+- if (error != NULL) {
+- g_warning ("%s", error->message);
+- exit (1);
+- }
++ if (!gtk_init_with_args (&argc, &argv, " - fail whale",
++ entries, GETTEXT_PACKAGE,
++ &error)) {
++ if (error != NULL) {
++ g_warning ("%s", error->message);
++ exit (1);
++ }
++
++ /* display server probably went away. Could be for legitimate reasons, could be for
++ * unexpected reasons. If it went away unexpectantly, that's logged elsewhere, so
++ * let's not add noise by logging here.
++ */
++ return 0;
++ }
+
+ fail_dialog = g_object_new (GSM_TYPE_FAIL_WHALE_DIALOG, NULL);
+ fail_dialog->priv->debug_mode = debug_mode;
diff --git a/testing/gnome-session/no-rpmatch.patch b/testing/gnome-session/no-rpmatch.patch
new file mode 100644
index 0000000000..ea41bf46e5
--- /dev/null
+++ b/testing/gnome-session/no-rpmatch.patch
@@ -0,0 +1,15 @@
+$OpenBSD: patch-gnome-session_main_c,v 1.19 2017/04/17 10:51:02 ajacoutot Exp $
+
+XXX no rpmatch(3) on OpenBSD
+
+--- a/gnome-session/main.c.orig Wed Apr 12 16:35:48 2017
++++ b/gnome-session/main.c Mon Apr 17 12:40:35 2017
+@@ -311,7 +311,7 @@ main (int argc, char **argv)
+
+ debug_string = g_getenv ("GNOME_SESSION_DEBUG");
+ if (debug_string != NULL) {
+- debug = rpmatch (debug_string) == TRUE || atoi (debug_string) == 1;
++ debug = atoi (debug_string) == 1;
+ }
+
+ error = NULL;