aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-phoenix
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-03 14:55:38 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-03 15:22:00 +0000
commite42557c1a763adf485ff34930e1c56e27456f699 (patch)
tree4ffd6f4ff7aec30431932f3ec7596edf353f0a63 /testing/go-phoenix
parent28f6c599a6f3f13fc45eeb6ae2d72e60cec1c5dc (diff)
downloadaports-e42557c1a763adf485ff34930e1c56e27456f699.tar.bz2
aports-e42557c1a763adf485ff34930e1c56e27456f699.tar.xz
testing/go-phoenix: new aport
Go library providing support functionality for application startup, configuration, logging, and profiling
Diffstat (limited to 'testing/go-phoenix')
-rw-r--r--testing/go-phoenix/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/go-phoenix/APKBUILD b/testing/go-phoenix/APKBUILD
new file mode 100644
index 0000000000..1d9e6d3c30
--- /dev/null
+++ b/testing/go-phoenix/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=go-phoenix
+_realname=phoenix
+_vendor="strukturag"
+pkgver=1.0.2
+_ver=${pkgver//./}
+pkgrel=0
+pkgdesc="Go library providing support functionality for application startup, configuration, logging, and profiling."
+url="https://github.com/$_vendor/$_realname"
+arch="noarch"
+license="Custom"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/strukturag/$_realname/archive/${_realname}_v$_ver.tar.gz"
+builddir="$srcdir"/$_realname-${_realname}_v$_ver
+
+
+prepare() {
+ cd "$builddir"
+}
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ for file in \
+ LICENSE \
+ README.md \
+ COPYRIGHT \
+ AUTHORS \
+ ; do \
+ test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
+ done
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+}
+
+md5sums="edd9fa60d9e58c74445e502843e14397 go-phoenix-1.0.2.tar.gz"
+sha256sums="33f4fbe37c478d5f023c1004e93eb1bf5bee56c4c41eba555ebc7442812318c8 go-phoenix-1.0.2.tar.gz"
+sha512sums="7b673e57135098b99fcc54cbe6b72dbd84a0342e2f8371e3b815e0a7598c2e4d4dccbbe6a71d250b88f9ad9ce285a4e108886ff3d2a77acc7eba1cf19bd4f7a2 go-phoenix-1.0.2.tar.gz"