aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-phoenix
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 09:23:39 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 09:23:39 +0000
commitec0387e275a734407a7956fa3bb8308f2a06b7f2 (patch)
tree8d135f18786d3be03853fb51e83d4384fe17a7d2 /testing/go-phoenix
parent191a4972c9c85c4262e65906f09192b50a2122a8 (diff)
downloadaports-ec0387e275a734407a7956fa3bb8308f2a06b7f2.tar.bz2
aports-ec0387e275a734407a7956fa3bb8308f2a06b7f2.tar.xz
testing/go-phoenix: modernize APKBUILD, update license, disable check()
Take maintainership
Diffstat (limited to 'testing/go-phoenix')
-rw-r--r--testing/go-phoenix/APKBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/testing/go-phoenix/APKBUILD b/testing/go-phoenix/APKBUILD
index 1d9e6d3c30..9d53f9b6ad 100644
--- a/testing/go-phoenix/APKBUILD
+++ b/testing/go-phoenix/APKBUILD
@@ -5,26 +5,18 @@ _realname=phoenix
_vendor="strukturag"
pkgver=1.0.2
_ver=${pkgver//./}
-pkgrel=0
+pkgrel=1
pkgdesc="Go library providing support functionality for application startup, configuration, logging, and profiling."
url="https://github.com/$_vendor/$_realname"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="BSD-3-Clause"
subpackages="$pkgname-doc"
+options="!check" # no testsuite
source="$pkgname-$pkgver.tar.gz::https://github.com/strukturag/$_realname/archive/${_realname}_v$_ver.tar.gz"
builddir="$srcdir"/$_realname-${_realname}_v$_ver
-
-prepare() {
- cd "$builddir"
-}
-
build() {
- cd "$builddir"
+ return 0
}
package() {
@@ -33,15 +25,13 @@ package() {
"$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
for file in \
LICENSE \
- README.md \
+ README.* \
COPYRIGHT \
AUTHORS \
; do \
test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
}
-md5sums="edd9fa60d9e58c74445e502843e14397 go-phoenix-1.0.2.tar.gz"
-sha256sums="33f4fbe37c478d5f023c1004e93eb1bf5bee56c4c41eba555ebc7442812318c8 go-phoenix-1.0.2.tar.gz"
sha512sums="7b673e57135098b99fcc54cbe6b72dbd84a0342e2f8371e3b815e0a7598c2e4d4dccbbe6a71d250b88f9ad9ce285a4e108886ff3d2a77acc7eba1cf19bd4f7a2 go-phoenix-1.0.2.tar.gz"