aboutsummaryrefslogtreecommitdiffstats
path: root/testing/goomwwm
diff options
context:
space:
mode:
authorMichael Pirogov <vbnet.ru@gmail.com>2017-04-14 17:06:52 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 10:50:00 +0000
commit6ef185863d02432829a798fa28d887631833e187 (patch)
tree8faa0a3beff744050be230d2471143a73c058504 /testing/goomwwm
parentee2ec5bb10d8c00776e91f9fd768f2b4489ae97f (diff)
downloadaports-6ef185863d02432829a798fa28d887631833e187.tar.bz2
aports-6ef185863d02432829a798fa28d887631833e187.tar.xz
testing/goomwwm: new aport
Get out of my way, Window Manager! https://github.com/seanpringle/goomwwm
Diffstat (limited to 'testing/goomwwm')
-rw-r--r--testing/goomwwm/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/goomwwm/APKBUILD b/testing/goomwwm/APKBUILD
new file mode 100644
index 0000000000..da0904f50b
--- /dev/null
+++ b/testing/goomwwm/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname=goomwwm
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Get out of my way, Window Manager!"
+url="https://github.com/seanpringle/goomwwm"
+arch="all"
+license="MIT"
+depends="libxft libx11 libxinerama freetype"
+makedepends="libx11-dev libxft-dev freetype-dev libxinerama-dev libx11 libxft pkgconfig xineramaproto xproto"
+source="${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+builddir="$srcdir/"
+_builddir="${builddir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "${_builddir}"
+ make proto normal
+}
+
+check() {
+ cd "${_builddir}"
+ ./${pkgname} --version
+}
+
+package() {
+ mkdir -p "${pkgdir}"
+ install -m755 -D "${_builddir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
+
+sha512sums="e37d80c8ea47fe136172c392521ec8d4dab361c3469d3d1626ed7c30385513301983c0ffde39f4c2e6f2dee8709da6a34f14f7bb89776f1ccde5103ab1a26764 goomwwm-1.0.0.tar.gz"