aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gpg-remailer/APKBUILD
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-05-06 02:53:36 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-05-06 14:56:14 +0200
commit49751a9a67e7bf6df04a474f6734989441148949 (patch)
tree7540eb67fb0420e72e2a7159753472e0888bedf0 /testing/gpg-remailer/APKBUILD
parent31f4e002d0f23414ec8d19a8f8656d2de01bbc20 (diff)
downloadaports-49751a9a67e7bf6df04a474f6734989441148949.tar.bz2
aports-49751a9a67e7bf6df04a474f6734989441148949.tar.xz
testing/gpg-remailer: new aport
https://fbb-git.github.io/gpg-remailer/ decrypt messages and re-encrypt them to a well-defined group
Diffstat (limited to 'testing/gpg-remailer/APKBUILD')
-rw-r--r--testing/gpg-remailer/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/gpg-remailer/APKBUILD b/testing/gpg-remailer/APKBUILD
new file mode 100644
index 0000000000..614ad92fe2
--- /dev/null
+++ b/testing/gpg-remailer/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Shiz <hi@shiz.me>
+# Maintainer: Shiz <hi@shiz.me>
+pkgname=gpg-remailer
+pkgver=3.02.01
+pkgrel=0
+pkgdesc="Decrypt GPG messages and re-encrypt them to a well-defined group"
+url="https://fbb-git.github.io/gpg-remailer/"
+arch="all"
+license="GPL3+"
+makedepends="icmake bash yodl bobcat-dev"
+subpackages="$pkgname-doc"
+source="gpg-remailer-$pkgver.tar.gz::https://github.com/fbb-git/gpg-remailer/archive/$pkgver.tar.gz
+ avoid-gnuisms.patch"
+builddir="$srcdir/gpg-remailer-$pkgver/gpg-remailer"
+
+build() {
+ cd "$builddir"
+ ./build program strip
+ ./build man
+}
+
+check() {
+ cd "$builddir"
+ ./tmp/bin/binary --version
+}
+
+package() {
+ cd "$builddir"
+ ./build install bm "$pkgdir"
+ # remove HTML documentation.
+ rm -rf "$pkgdir"/usr/share/doc
+}
+
+sha512sums="c26117d8c58989ce1231b40fef99919ada1df70652aca6b309baab38186aadb5b2fc73c652f5d47cd2b044abe086338a4124a7c6c0df241d330e22f2711b1a76 gpg-remailer-3.02.01.tar.gz
+7b3528add0f0c62f999719499fbd043b0926f9440fc0a626e8b2de26ca2aebd6dfde8e3d6180ee45cf45c9883908975266b4e91a6b998178c35a57dcd3a1f937 avoid-gnuisms.patch"