aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handbrake
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-05 17:33:57 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-05 17:33:57 +0200
commit59272ef798df3c361d7399a419e9c76a74ddcf3b (patch)
treeed9d669ed679822f523c8632b8fbd79aede9ede0 /testing/handbrake
parentc172eceed77bc0330347b09a284d86d99da6146f (diff)
downloadaports-59272ef798df3c361d7399a419e9c76a74ddcf3b.tar.bz2
aports-59272ef798df3c361d7399a419e9c76a74ddcf3b.tar.xz
testing/handbrake: build fix
Diffstat (limited to 'testing/handbrake')
-rw-r--r--testing/handbrake/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/handbrake/APKBUILD b/testing/handbrake/APKBUILD
index 1f7b3d395c..6d6c307153 100644
--- a/testing/handbrake/APKBUILD
+++ b/testing/handbrake/APKBUILD
@@ -13,7 +13,8 @@ makedepends="yasm autoconf libtool zlib-dev libbz2 libogg-dev libtheora-dev
libvorbis-dev libsamplerate-dev fribidi-dev freetype-dev
tinyxml-dev fontconfig-dev libass-dev intltool glib-dev dbus-glib-dev
gtk+3.0-dev webkitgtk-dev eudev-dev libnotify-dev libdvdread-dev
- gstreamer0.10-dev x264-dev lame-dev linux-headers cmake"
+ gstreamer0.10-dev x264-dev lame-dev linux-headers cmake
+ autoconf automake"
subpackages="$pkgname-lang $pkgname-gtk"
source="${_pkgname}-${pkgver}.tar.bz2::https://handbrake.fr/rotation.php?file=${_pkgname}-${pkgver}.tar.bz2"
@@ -21,12 +22,12 @@ _builddir="$srcdir"/${_pkgname}-${pkgver}
build() {
cd "$_builddir"
- ./configure --prefix=/usr || return 1
+ ./configure --prefix=/usr || return 1
cd build
# This is retarded, but handbrake's "custom.defs" doesn't seem to work
- make ffmpeg.configure
- make ffmpeg.build CFLAGS="-D_GNU_SOURCE -I${_builddir}/build/contrib/include -I."
+ make ffmpeg.configure || return 1
+ make ffmpeg.build CFLAGS="-D_GNU_SOURCE -I${_builddir}/build/contrib/include -I." || return 1
make build CFLAGS="-I${_builddir}/build/contrib/include -I." || return 1