aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handlebars
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-26 18:09:13 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-26 18:09:51 +0200
commitab445e3c175b44a854e99b319e2906ef4a39c6c0 (patch)
tree8b632e88cd73e835cc30b14812ff1d1c6946c9db /testing/handlebars
parentda228851ed762b6a7924b310bab03d0638f73129 (diff)
downloadaports-ab445e3c175b44a854e99b319e2906ef4a39c6c0.tar.bz2
aports-ab445e3c175b44a854e99b319e2906ef4a39c6c0.tar.xz
testing/handlebars: fix test failure on ppc64le
Diffstat (limited to 'testing/handlebars')
-rw-r--r--testing/handlebars/APKBUILD16
-rw-r--r--testing/handlebars/fix-test-failure-on-ppc64le.patch25
2 files changed, 31 insertions, 10 deletions
diff --git a/testing/handlebars/APKBUILD b/testing/handlebars/APKBUILD
index 73e55f4a7c..d376fe243b 100644
--- a/testing/handlebars/APKBUILD
+++ b/testing/handlebars/APKBUILD
@@ -3,7 +3,7 @@
pkgname=handlebars
_pkgname=handlebars.c
pkgver=0.6.4
-pkgrel=0
+pkgrel=1
_mustachespec_ver="1.1.3"
_handlebarsspec_ver="4.0.5-p1"
pkgdesc="C implementation of handlebars.js"
@@ -15,7 +15,8 @@ makedepends="autoconf automake bison check-dev flex json-c-dev libtool lmdb-dev
subpackages="$pkgname-dev $pkgname-utils"
source="$_pkgname-$pkgver.tar.gz::https://github.com/jbboehr/$_pkgname/archive/v$pkgver.tar.gz
mustache-spec-$_mustachespec_ver.tar.gz::https://github.com/mustache/spec/archive/v$_mustachespec_ver.tar.gz
- handlebars-spec-$_handlebarsspec_ver.tar.gz::https://github.com/jbboehr/handlebars-spec/archive/v$_handlebarsspec_ver.tar.gz"
+ handlebars-spec-$_handlebarsspec_ver.tar.gz::https://github.com/jbboehr/handlebars-spec/archive/v$_handlebarsspec_ver.tar.gz
+ fix-test-failure-on-ppc64le.patch"
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
@@ -41,13 +42,7 @@ build() {
check() {
cd "$builddir"
-
- case "$CARCH" in
- # XXX: Ignore tests failures on ppc64le for now.
- # https://github.com/jbboehr/handlebars.c/issues/67
- ppc64le) make test || true;;
- *) make test;;
- esac
+ make test
}
package() {
@@ -64,4 +59,5 @@ utils() {
sha512sums="fae85ac30ce85b089c79c8b67cbf96cc94527d6b1ee2e83d05e638662c85b9bb1bd2aee06168dcd1ae2a15879f9f218dbecac012c25b583749d61f0921e0af16 handlebars.c-0.6.4.tar.gz
801a9cbf8a39080b183b20fbf327b420bcd6ed162bb58165dabafeb45fae277a9da506b6639ee7b955f6c206f0b8826d39588a43ffd86ab5ef4be6e9be2bc842 mustache-spec-1.1.3.tar.gz
-81f0ff5ffc2d6b72465bdcbd2325d022faf73ec79586f3d8dfb07b7a6ec9147280872a82184b8d7ecdd8b22611b6b420c02ab437794bcd0aba67d2bf2082bc5d handlebars-spec-4.0.5-p1.tar.gz"
+81f0ff5ffc2d6b72465bdcbd2325d022faf73ec79586f3d8dfb07b7a6ec9147280872a82184b8d7ecdd8b22611b6b420c02ab437794bcd0aba67d2bf2082bc5d handlebars-spec-4.0.5-p1.tar.gz
+41a75d3e48d9eee2a404f41d5779d104895b72d4e8f9d00b207b468fc832ddc76fcd268fee3939cfb89f1dbba8149b39a7cef3b781c0f0da0b7abbbab55d3fec fix-test-failure-on-ppc64le.patch"
diff --git a/testing/handlebars/fix-test-failure-on-ppc64le.patch b/testing/handlebars/fix-test-failure-on-ppc64le.patch
new file mode 100644
index 0000000000..2bb2807707
--- /dev/null
+++ b/testing/handlebars/fix-test-failure-on-ppc64le.patch
@@ -0,0 +1,25 @@
+From 931ad82c17984935decebacd3283e9d26ca749cb Mon Sep 17 00:00:00 2001
+From: John Boehr <jbboehr@gmail.com>
+Date: Tue, 25 Jul 2017 20:02:12 -0700
+Subject: [PATCH] Should fix test failure on Alpine Linux ppc64le
+
+#67
+
+Patch-Source: https://github.com/jbboehr/handlebars.c/pull/68
+---
+ tests/test_spec_handlebars_parser.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_spec_handlebars_parser.c b/tests/test_spec_handlebars_parser.c
+index 6345e3a..7c6472d 100644
+--- a/tests/test_spec_handlebars_parser.c
++++ b/tests/test_spec_handlebars_parser.c
+@@ -160,7 +160,7 @@ static int loadSpec(const char * filename) {
+
+ // Allocate tests array
+ tests_size = array_len + 1;
+- tests = handlebars_talloc_array(rootctx, struct parser_test, tests_size);
++ tests = talloc_zero_array(rootctx, struct parser_test, tests_size);
+
+ // Iterate over array
+ for( int i = 0; i < array_len; i++ ) {