aboutsummaryrefslogtreecommitdiffstats
path: root/testing/haxe
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2017-10-16 12:28:02 +0800
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-19 04:58:11 +0000
commitb496b8bf29f6c590d7d3d9e50cb5d528dca34912 (patch)
tree15af60871d3359a5ae061d7f07407a4c72dbac54 /testing/haxe
parent2c935a09543a227f81c330fb4b71d3a40ad5c0dd (diff)
downloadaports-b496b8bf29f6c590d7d3d9e50cb5d528dca34912.tar.bz2
aports-b496b8bf29f6c590d7d3d9e50cb5d528dca34912.tar.xz
testing/haxe: update to 3.4.4
Diffstat (limited to 'testing/haxe')
-rw-r--r--testing/haxe/APKBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index 5121ae53ed..f1506cd9b0 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -1,21 +1,21 @@
# Contributor: Jon Ong <jonongjs@rottenmage.com>
-# Maintainer:
+# Maintainer: Andy Li <andy@onthewings.net>
pkgname=haxe
-pkgver=3.3.0
-_versuffix=-rc1
+pkgver=3.4.4
+_versuffix=
pkgrel=0
pkgdesc="Cross-platform toolkit and programming language"
-url="http://haxe.org"
-arch="x86_64 ppc64le"
+url="https://haxe.org"
+arch="all"
license="GPL MIT LGPL" # http://haxe.org/foundation/open-source.html
depends=""
-makedepends="camlp4 ocaml neko-dev zlib-dev"
+makedepends="camlp4 ocaml neko-dev zlib-dev pcre-dev"
options="!strip !makeflags"
install=""
subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/HaxeFoundation/haxe/archive/${pkgver}${_versuffix}.tar.gz
- haxelib.tar.gz::https://github.com/HaxeFoundation/haxelib/archive/3.3.0.tar.gz
- https://github.com/HaxeFoundation/ocamllibs/archive/fa103c7d734f27afc5d8197144eb7ab9338f9a76.tar.gz
+ haxelib.tar.gz::https://github.com/HaxeFoundation/haxelib/archive/eeac8f4e77b23b120f27d27502f43589db26d143.tar.gz
+ ocamllibs.tar.gz::https://github.com/HaxeFoundation/ocamllibs/archive/0e6ea857c0f7df5e69628f949d0d33a3ce5552a8.tar.gz
haxe.sh
"
@@ -27,10 +27,18 @@ build() {
mv "$srcdir"/haxelib-* extra/haxelib_src || return 1
mv "$srcdir"/ocamllibs-* libs || return 1
- make -j1 || return 1
+ # Check to see if ocamlopt exists. If not, bytecompile everything.
+ command -v ocamlopt && make -j1 || make -j1 BYTECODE=1 || return 1
make -j1 tools || return 1
}
+check() {
+ cd "$_builddir"
+
+ ./haxe -version || return 1
+ ./haxelib version || return 1
+}
+
package() {
cd "$_builddir"
install -d "$pkgdir"/usr/bin/ "$pkgdir"/usr/share/haxe/
@@ -39,15 +47,7 @@ package() {
install -Dm 644 extra/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
install -Dm 644 "$srcdir/haxe.sh" "$pkgdir/etc/profile.d/haxe.sh"
}
-md5sums="f87f1c66dca0790078c38cd65db7c922 haxe-3.3.0.tar.gz
-b95523bdebe94d8485a0e23124f7befc haxelib.tar.gz
-245eea75aefbba295c30334d226c6c62 fa103c7d734f27afc5d8197144eb7ab9338f9a76.tar.gz
-977476c8fc1dfc0acbb05bd22f9136b0 haxe.sh"
-sha256sums="3c5abdecae2bea5942cef1845ca5e71845ec29d535142c617d000c531722e165 haxe-3.3.0.tar.gz
-f0942745ea150d81a41dc49d1b9c7ddf397391af0c9bf7209fb5a9ef20f6101c haxelib.tar.gz
-6426e537addc8ba88dba47acbcdd010a47557b62da1e3d32cb251d559b9fc73f fa103c7d734f27afc5d8197144eb7ab9338f9a76.tar.gz
-da08272cf61872f3401ad8b9f0bf94a4b2bfbaeb7b65644ee822f4ac8aaaed10 haxe.sh"
-sha512sums="53a8ea15393fcc203d90a1d26dd3d8e838b4653b27b075455f1f79e93cd34ce33a22b9def495a2e01afe851f0ab5cb702b63cd6d48addd4d1bd4f35908e8bb1b haxe-3.3.0.tar.gz
-04f4b4cd3c82750c79cdb54b1874ce4624791c4ef0c3e79fe929c39375e2aa70c244fa38cc0fd46b65fdbf0dbc711774618d28de1f66220ef6b56bc3b74021bf haxelib.tar.gz
-3430849201a8c875d64693af7f52b05ce4f701305d2833f0ff96494e875858394c5ec5ed9f911058df63a83454386c9edbe1221114435f4b0a1d2beb0f43b72d fa103c7d734f27afc5d8197144eb7ab9338f9a76.tar.gz
+sha512sums="e6f3dc4659ff785b8ffbe2fcc4fcee75afe66b848e1423f4e63cec383d2f99d54332d9f0812eb3b1931847f2429c4dbc64caedbf9afca750598292ce34f5522a haxe-3.4.4.tar.gz
+711a58dae9311a2614467a04b294c6b0b3064849d4840f98d24c152a49abf856c79567aa810c59701e76d42db43359c04ae29a8b5d0404132b5cd107ae6b58e1 haxelib.tar.gz
+a09864fa5b00210695f9d1d5f6b4c4f0a5f37ec7c5020671e32185e0f205e46535103673eaa1a585627e7aebc4b64185414c6cd4dd59f12bfda2191d372be3b5 ocamllibs.tar.gz
c756571769bcdb0d7040b44b3d486e445c56a01a8d23d26f668be19b8d147e9f324166f004872d04e912f329e45ad821672a0a365df4ba27fb1dc22bb34130a3 haxe.sh"