aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hdf5
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2015-07-14 22:56:36 -0700
committerFrancesco Colista <fcolista@alpinelinux.org>2015-07-17 06:16:29 +0000
commit79e70b542e8b60fd980549f5b077f64faecf0ca4 (patch)
treeb7e348ffa9b97bb36d1f8c9a1b98b9968a72b54b /testing/hdf5
parentc70458249b68ce79fd5b5c8c7d6c5fe63794644e (diff)
downloadaports-79e70b542e8b60fd980549f5b077f64faecf0ca4.tar.bz2
aports-79e70b542e8b60fd980549f5b077f64faecf0ca4.tar.xz
testing/hdf5: new aport
HDF5 is a library for handling the HDF5 data file format. Meep (MIT Electromagnetic Equation Propagation) and other programs use this format and library.
Diffstat (limited to 'testing/hdf5')
-rw-r--r--testing/hdf5/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/testing/hdf5/APKBUILD b/testing/hdf5/APKBUILD
new file mode 100644
index 0000000000..6e41167b5d
--- /dev/null
+++ b/testing/hdf5/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer:
+#
+# make test does not complete without error on all systems;
+# the bug is somewhere in src/H5Omtime.c, unless the test is wrong.
+# Essentially, when the timezone is not UTC, it adjusts the ctime it
+# reads one way and the "known" datestamp the other way.
+# I'm not sure if this is musl-specific or not.
+# With TZ=UTC, all tests pass.
+#
+# HDF5 depends on zlib and provides a C interface by default.
+# Optionally, it can be built with szip (which has limitations on
+# commercial use and thus is non-free), MPI, and C++ and Fortran bindings.
+# C++ and Fortran bindings may not be thread-safe:
+# building either and passing --enable-threadsafe is unsupported.
+
+pkgname=hdf5
+_pkgver=1.8.15-patch1
+pkgver=1.8.15.1
+pkgrel=0
+pkgdesc="HDF5 is a data model, library, and file format for storing and managing data"
+url="http://www.hdfgroup.org/HDF5/"
+arch="all"
+license="custom"
+depends=""
+depends_dev="zlib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-$_pkgver.tar.bz2"
+
+_builddir="$srcdir"/hdf5-$_pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-threadsafe \
+ --enable-direct-vfd \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -d "$pkgdir"/usr/share/licenses/"$pkgname"
+ install -c -m 0644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="3c0d7a8c38d1abc7b40fc12c1d5f2bb8 hdf5-1.8.15-patch1.tar.bz2"
+sha256sums="a5afc630c4443547fff15e9637b5b10404adbed4c00206d89517d32d6668fb32 hdf5-1.8.15-patch1.tar.bz2"
+sha512sums="380c06f3cab469351d6ddc940c7cdffd5bd20a74e69cb4d549989bec5f130dadae11c04928ead7eea0200a175fc45a042d068a752d8a9c19a35c3a6912a147bd hdf5-1.8.15-patch1.tar.bz2"