aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hidapi
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-11-18 13:05:06 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-04-03 21:21:16 +0200
commit40f878f0f32688048ed3702e44104e2084a5bb35 (patch)
tree50025b37be834aeab1e2a0a6a1ad2b3e8d8e51c6 /testing/hidapi
parentd9acf8f5e55c46941ce9a491ce8812cfbfb750c4 (diff)
downloadaports-40f878f0f32688048ed3702e44104e2084a5bb35.tar.bz2
aports-40f878f0f32688048ed3702e44104e2084a5bb35.tar.xz
testing/hidapi: new aport
Diffstat (limited to 'testing/hidapi')
-rw-r--r--testing/hidapi/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/hidapi/APKBUILD b/testing/hidapi/APKBUILD
new file mode 100644
index 0000000000..6397d367b7
--- /dev/null
+++ b/testing/hidapi/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=hidapi
+pkgver=0.8.0_rc1
+_relver="$(echo "$pkgver" | sed s/_/-/)"
+pkgrel=0
+pkgdesc="Simple library for communicating with USB and Bluetooth HID devices"
+url="http://www.signal11.us/oss/hidapi/"
+arch="all"
+license="custom"
+depends=""
+depends_dev=""
+options="!check"
+makedepends="libusb-dev libtool eudev-dev linux-headers autoconf automake"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/signal11/$pkgname/archive/$pkgname-${_relver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$_relver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./bootstrap
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ mv "$pkgdir"/usr/share/doc/$pkgname/LICENSE* \
+ "$pkgdir"/usr/share/licenses/$pkgname
+}
+
+sha512sums="4529d74e715c47d788b533d94bf0ef35fa773240c9a59558d30c5ecc78cf46961de368f9385f5d84d378eaf8d4e941d553341e839674e562ccfcf52726620a65 hidapi-0.8.0_rc1.tar.gz"