aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hitch
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-08-04 21:23:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-08-10 08:02:30 +0000
commitf5cbdfdb7374aee6392d70ae5f38bd6bf07577e6 (patch)
tree5cab0f505ca53c6f32edca5df11595ab00294e92 /testing/hitch
parent7737befd3c9fa683981c754c2958fcfb199cf394 (diff)
downloadaports-f5cbdfdb7374aee6392d70ae5f38bd6bf07577e6.tar.bz2
aports-f5cbdfdb7374aee6392d70ae5f38bd6bf07577e6.tar.xz
testing/hitch: upgrade to 1.4.6 and modernize
Diffstat (limited to 'testing/hitch')
-rw-r--r--testing/hitch/APKBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/testing/hitch/APKBUILD b/testing/hitch/APKBUILD
index 45d4e6ded1..d2152420ad 100644
--- a/testing/hitch/APKBUILD
+++ b/testing/hitch/APKBUILD
@@ -1,38 +1,33 @@
# Contributor: Raphael Cohn <raphael.cohn@stormmq.com>
# Maintainer: Raphael Cohn <raphael.cohn@stormmq.com>
pkgname=hitch
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.4.6
+pkgrel=0
pkgdesc="hitch is a TLS / SSL endpoint like stunnel"
url="https://hitch-tls.org/"
arch="all"
license="BSD"
depends="libev"
-depends_dev=""
makedepends="libev-dev libressl-dev automake autoconf py-docutils bison flex"
-install=""
subpackages="$pkgname-doc"
-source="https://github.com/varnish/hitch/archive/hitch-1.2.0.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/varnish/$pkgname/archive/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/hitch-hitch-$pkgver
+builddir="$srcdir"/$pkgname-$pkgname-$pkgver
build() {
cd "$builddir"
- ./bootstrap || return 1
+ ./bootstrap
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="92378e514ae235755d9fade27e2d9f95 hitch-1.2.0.tar.gz"
-sha256sums="129c26f5bc7bf9ae3c3458af5dd3d9dc96007eab70cf603c9859355beea36b51 hitch-1.2.0.tar.gz"
-sha512sums="bf5014211bfa82240b3e850e4800534436ff41665a9422e9ed5acdbcbb01ba3b0e98c8c1fcb572edb8ea67e15c1169583ed7a04c49d2015a8b99f179c4718178 hitch-1.2.0.tar.gz"
+sha512sums="98caf993aee7b562a39560fc9c634497636e19b295c8a71306b1e1964d5dea5efc14f0b7faa50bff3448b8977ce15521fbce9dc5ceea9f02162c8ebd18ed4eda hitch-1.4.6.tar.gz"