aboutsummaryrefslogtreecommitdiffstats
path: root/testing/homebank
diff options
context:
space:
mode:
author7heo <7heo@mail.com>2017-07-02 02:52:16 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-08 05:02:40 +0000
commit9fd949cfd291dd91fc40fd36141a63ca46662125 (patch)
treea085e6ed11c2e44aba272e771c260ed5bcf7198e /testing/homebank
parentfb9b16e1489f84061e42cb5395b10d582f5f9319 (diff)
downloadaports-9fd949cfd291dd91fc40fd36141a63ca46662125.tar.bz2
aports-9fd949cfd291dd91fc40fd36141a63ca46662125.tar.xz
testing/homebank: new aport
Diffstat (limited to 'testing/homebank')
-rw-r--r--testing/homebank/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/homebank/APKBUILD b/testing/homebank/APKBUILD
new file mode 100644
index 0000000000..0e4838b069
--- /dev/null
+++ b/testing/homebank/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: 7heo <7heo@mail.com>
+# Maintainer: 7heo <7heo@mail.com>
+pkgname=homebank
+pkgver=5.1.5
+pkgrel=0
+pkgdesc="Free personal finance software, money management"
+url="http://homebank.free.fr/"
+arch="all"
+license="GPL"
+makedepends="bash gtk+3.0-dev libsoup-dev libofx-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://homebank.free.fr/public/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ "$builddir"/src/homebank --version | grep -q "^$pkgname $pkgver$"
+}
+
+package() {
+ cd "$builddir"
+ chmod a+x install-sh
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="674a6385f427ba23039745b476d7474c9f41f0183d5a41d6fa340fe36cc9b0b3a4a3da30dfecc4c4c3b8bfc72aba751799a5750b71eaf28b13333475d31e92e0 homebank-5.1.5.tar.gz"