aboutsummaryrefslogtreecommitdiffstats
path: root/testing/httrack
diff options
context:
space:
mode:
authorxming <xmingske@gmail.com>2014-09-19 09:59:49 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-09-19 12:10:31 +0200
commit86223c49db081552562538adebbf547f6cbebe14 (patch)
treef362207e1f6a5a1f11b096beb195591058bcaebf /testing/httrack
parent4c930edc7669ac008cc077cd00afb4a380641581 (diff)
downloadaports-86223c49db081552562538adebbf547f6cbebe14.tar.bz2
aports-86223c49db081552562538adebbf547f6cbebe14.tar.xz
testing/httrack: new aport
Website Copier - Free Software Offline Browser http://www.httrack.com/
Diffstat (limited to 'testing/httrack')
-rw-r--r--testing/httrack/APKBUILD56
-rw-r--r--testing/httrack/compile_fix.patch22
2 files changed, 78 insertions, 0 deletions
diff --git a/testing/httrack/APKBUILD b/testing/httrack/APKBUILD
new file mode 100644
index 0000000000..69c55ed2e8
--- /dev/null
+++ b/testing/httrack/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=httrack
+pkgver=3.48.19
+pkgrel=0
+pkgdesc="Website Copier - Free Software Offline Browser"
+url="http://www.httrack.com/"
+arch="all"
+license="GPL3"
+depends=""
+makedepends="zlib-dev"
+source="http://mirror.httrack.com/${pkgname}-${pkgver}.tar.gz
+ compile_fix.patch
+ "
+subpackages="$pkgname-doc"
+
+_builddir="${srcdir}"/${pkgname}-${pkgver}
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static \
+ --disable-dependency-tracking \
+ --localstatedir=/var/lib \
+ --docdir=/usr/share/doc/httrack \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+ find "${pkgdir}"/usr/lib/ -type f -name '*.la' -delete || return 1
+}
+
+md5sums="db07a1a3e41eff1123606c444f8f267d httrack-3.48.19.tar.gz
+df5a7d5cc9be56a08a6c362152256f2b compile_fix.patch"
+sha256sums="16f0cd0ea21042106879238fe4892b56018e106347d69dcb0b93816ee8f68afe httrack-3.48.19.tar.gz
+4bd329ae0c07bcc7905fd56c9da9b04876130e5d521a64ad43c961f87944aab6 compile_fix.patch"
+sha512sums="c7202c4d86963fe935ce1f1a81f43f47544e03e4743528f52acd541ba87d6ef47d9e691b432f9bebedbf06e764bd67fe85748762b6ec3c09491b7528957cda8b httrack-3.48.19.tar.gz
+41534bac32d0f3b94a862d1fe94726dc41407b8fccdf42d8755522b47c8975860f25e5c0c6150900faee3c9b7f1b19fdaa2167c9f4f2f7d63a1a62df29ce36ed compile_fix.patch"
diff --git a/testing/httrack/compile_fix.patch b/testing/httrack/compile_fix.patch
new file mode 100644
index 0000000000..ad7aebce11
--- /dev/null
+++ b/testing/httrack/compile_fix.patch
@@ -0,0 +1,22 @@
+--- a/src/httrack.c
++++ b/src/httrack.c
+@@ -69,7 +69,8 @@
+ #include <unistd.h>
+ #endif
+ #include <ctype.h>
+-#ifdef __linux
++//#ifdef __linux
++#ifdef __GLIBC__
+ #include <execinfo.h>
+ #endif
+ /* END specific definitions */
+@@ -878,7 +879,8 @@
+ #define FD_ERR 2
+
+ static void print_backtrace(void) {
+-#ifdef __linux
++//#ifdef __linux
++#ifdef __GLIBC__
+ void *stack[256];
+ const int size = backtrace(stack, sizeof(stack)/sizeof(stack[0]));
+ if (size != 0) {