aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icoutils
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-04-27 19:13:11 +0200
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-24 07:50:11 +0000
commitf61ff84cad4708bc468d35e656f64096daacc896 (patch)
tree93143198648619235e3c78a5ba56149ce8e84632 /testing/icoutils
parentc7267903b7c514aaa665e957d3f30fe5a5d75c02 (diff)
downloadaports-f61ff84cad4708bc468d35e656f64096daacc896.tar.bz2
aports-f61ff84cad4708bc468d35e656f64096daacc896.tar.xz
testing/icoutils: new aport
Diffstat (limited to 'testing/icoutils')
-rw-r--r--testing/icoutils/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/icoutils/APKBUILD b/testing/icoutils/APKBUILD
new file mode 100644
index 0000000000..6973e5a33d
--- /dev/null
+++ b/testing/icoutils/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=icoutils
+pkgver=0.32.3
+pkgrel=0
+pkgdesc="Extracts and converts images in MS Windows(R) icon and cursor files."
+url="https://www.nongnu.org/icoutils/"
+arch="all"
+license="GPL-3.0+"
+options="!check" # No test suite
+depends="perl-libwww"
+makedepends="automake autoconf libtool libpng-dev"
+subpackages="$pkgname-doc"
+source="https://download.savannah.gnu.org/releases/icoutils/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="982a051a5dc4a63bb2a9f23e78e5a88e481e5c7a9c25789253e1c396e40d4c093e5a9b399966d660e4f2da21ce15d539cb9d20bfd8126b1138f148b86baa6726 icoutils-0.32.3.tar.bz2"