aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ipmiutil
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 14:29:15 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 14:29:15 -0600
commit24b40294679cc770346c2dbe39080b4755ef40ce (patch)
treea3ede3d31299e07b7ec29eb34c03a2438722485f /testing/ipmiutil
parent528419501f1010b2bf0a34fcfaa7a38d90869943 (diff)
downloadaports-24b40294679cc770346c2dbe39080b4755ef40ce.tar.bz2
aports-24b40294679cc770346c2dbe39080b4755ef40ce.tar.xz
testing/ipmiutil: new aport
Diffstat (limited to 'testing/ipmiutil')
-rw-r--r--testing/ipmiutil/APKBUILD39
-rw-r--r--testing/ipmiutil/ipmiutil-3.0.7-fix-sha256.patch68
2 files changed, 107 insertions, 0 deletions
diff --git a/testing/ipmiutil/APKBUILD b/testing/ipmiutil/APKBUILD
new file mode 100644
index 0000000000..b7eee18dfa
--- /dev/null
+++ b/testing/ipmiutil/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: A. Wilcox <AWilcox@Wilcox-Tech.com>
+pkgname=ipmiutil
+pkgver=3.0.7
+pkgrel=0
+pkgdesc="IPMI Management Utilities"
+url="http://ipmiutil.sourceforge.net/"
+arch="all"
+options="!check" # No test suite shipped.
+license="BSD-2-clause BSD-3-clause GPL-2.0"
+depends=""
+depends_dev="openssl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/ipmiutil/ipmiutil-$pkgver.tar.gz
+ ipmiutil-3.0.7-fix-sha256.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-systemd \
+ --enable-sha256 \
+ --enable-gpl
+ make -j1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="26a0c805f2c49102eee44052814a6f7af67c74082489e70b058bd4350526a65aad1e1352e33b12e1afeae5e9e96fd2eb361fc6a112d38782dee58f95c3e2a13b ipmiutil-3.0.7.tar.gz
+74e8951bccd004f765b99de87dc5f04834e594b3e14ba885148fb971eaf15164ccac2de880e409f201a38cba5c0948a0fabc04e1e34fb396f50b1ecddb6b305b ipmiutil-3.0.7-fix-sha256.patch"
diff --git a/testing/ipmiutil/ipmiutil-3.0.7-fix-sha256.patch b/testing/ipmiutil/ipmiutil-3.0.7-fix-sha256.patch
new file mode 100644
index 0000000000..1cc1b55320
--- /dev/null
+++ b/testing/ipmiutil/ipmiutil-3.0.7-fix-sha256.patch
@@ -0,0 +1,68 @@
+--- ipmiutil-3.0.7/lib/Makefile.am.old 2017-09-20 10:08:20.000000000 -0500
++++ ipmiutil-3.0.7/lib/Makefile.am 2018-01-01 18:03:45.080832425 -0600
+@@ -33,10 +33,11 @@
+ else cp -f libipmiapi64.a.redhat libipmiapi.a; fi \
+ else cp -f libipmiapi32.a libipmiapi.a; fi \
+ fi
+- if [ "$(PLUSFLAGS)" = "-DHAVE_LANPLUS" ]; then \
+- cd lanplus; make clean; make ; \
+- pwd; cp -f libipmi_lanplus.a .. ; \
+- fi
++ case "$(PLUSFLAGS)" in \
++ "-DHAVE_LANPLUS"*) \
++ cd lanplus; make clean; make ; \
++ pwd; cp -f libipmi_lanplus.a .. ;; \
++ esac
+
+ clean:
+ rm -f libipmiapi.a lib*_lanplus.a lib*_lanplus.so
+@@ -51,10 +52,11 @@
+ cd lanplus; make distclean
+
+ install:
+- if [ "$(PLUSFLAGS)" = "-DHAVE_LANPLUS" ]; then \
+- $(MKDIR) ${datato} ; \
+- cd lanplus; make install ; \
+- fi
++ case "$(PLUSFLAGS)" in \
++ "-DHAVE_LANPLUS"*) \
++ $(MKDIR) ${datato} ; \
++ cd lanplus; make install ;; \
++ esac
+
+ check:
+
+--- ipmiutil-3.0.7/lib/Makefile.in.old 2017-09-20 10:08:28.000000000 -0500
++++ ipmiutil-3.0.7/lib/Makefile.in 2018-01-01 18:02:55.187678005 -0600
+@@ -392,10 +392,11 @@
+ else cp -f libipmiapi64.a.redhat libipmiapi.a; fi \
+ else cp -f libipmiapi32.a libipmiapi.a; fi \
+ fi
+- if [ "$(PLUSFLAGS)" = "-DHAVE_LANPLUS" ]; then \
+- cd lanplus; make clean; make ; \
+- pwd; cp -f libipmi_lanplus.a .. ; \
+- fi
++ case "$(PLUSFLAGS)" in \
++ "-DHAVE_LANPLUS"*) \
++ cd lanplus; make clean; make ; \
++ pwd; cp -f libipmi_lanplus.a .. ;; \
++ esac
+
+ clean:
+ rm -f libipmiapi.a lib*_lanplus.a lib*_lanplus.so
+@@ -410,10 +411,11 @@
+ cd lanplus; make distclean
+
+ install:
+- if [ "$(PLUSFLAGS)" = "-DHAVE_LANPLUS" ]; then \
+- $(MKDIR) ${datato} ; \
+- cd lanplus; make install ; \
+- fi
++ case "$(PLUSFLAGS)" in \
++ "-DHAVE_LANPLUS"*) \
++ $(MKDIR) ${datato} ; \
++ cd lanplus; make install ;; \
++ esac
+
+ check:
+