aboutsummaryrefslogtreecommitdiffstats
path: root/testing/laszip
diff options
context:
space:
mode:
authorBradley J Chambers <brad.chambers@gmail.com>2017-06-29 14:56:59 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 15:38:10 +0000
commit9d4ce8fa3e26756386b81c88f03470ed9e58a486 (patch)
tree43ae992ba9436355ce2d7cc99068ddec87431649 /testing/laszip
parentb6cabc796ebaf3025761bdcbab8614464a37597d (diff)
downloadaports-9d4ce8fa3e26756386b81c88f03470ed9e58a486.tar.bz2
aports-9d4ce8fa3e26756386b81c88f03470ed9e58a486.tar.xz
testing/laszip: new aport
https://github.com/LASzip/LASzip LASzip is a point cloud compression library.
Diffstat (limited to 'testing/laszip')
-rw-r--r--testing/laszip/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/laszip/APKBUILD b/testing/laszip/APKBUILD
new file mode 100644
index 0000000000..0e21e68b17
--- /dev/null
+++ b/testing/laszip/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bradley J Chambers <brad.chambers@gmail.com>
+# Maintainer: Bradley J Chambers <brad.chambers@gmail.com>
+pkgname=laszip
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="LASzip point cloud compression library"
+url="https://github.com/laszip/laszip"
+arch="all"
+license="LGPL2+"
+options="!check"
+makedepends="cmake"
+install=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/LASzip/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/LASzip-"$pkgver"
+
+build() {
+ cd "$builddir"
+
+ mkdir build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="910560e0b7201d4827b934d704acec5e3682f46b2532bc85896b210e787d79970986ceaaf96241e13db7ddcaa16fa63652b31bb75d285a7f768a6efd06374674 laszip-3.1.0.tar.gz"