aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbson
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-03-03 11:47:42 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-07 10:10:02 +0000
commit7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b (patch)
tree700bf34ca4d5052654ab5091ea1a58e48921c7f3 /testing/libbson
parent5c78920497d3a069c5200ec1f528bb7999cf2c82 (diff)
downloadaports-7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b.tar.bz2
aports-7e56c0aaff074e90cb6ab207d9c9a0bb8b40441b.tar.xz
testing/mongo-c-driver: build manual pages
Diffstat (limited to 'testing/libbson')
-rw-r--r--testing/libbson/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/testing/libbson/APKBUILD b/testing/libbson/APKBUILD
index abe9d130a6..2993dcfc2f 100644
--- a/testing/libbson/APKBUILD
+++ b/testing/libbson/APKBUILD
@@ -1,35 +1,41 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=libbson
pkgver=1.9.2
-pkgrel=1
+pkgrel=2
pkgdesc="routines related to building, parsing, and iterating BSON documents"
url="https://github.com/mongodb/libbson"
arch="all"
license="Apache-2.0"
-makedepends="$depends_dev autoconf automake libtool"
+depends=
+depends_dev=
+makedepends="$depends_dev autoconf automake libtool py3-sphinx"
checkdepends="bash"
+install=
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # segfaults
-source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/libbson/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/$pkgname/archive/$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$builddir"
- ./autogen.sh
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
cd "$builddir"
- ./configure --prefix=/usr \
+ SPHINX_BUILD=/usr/bin/sphinx-build-3 ./configure \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --enable-man-pages=yes \
+ --enable-tests=yes
make
}
check() {
cd "$builddir"
- make check
+ make TEST_ARGS=--no-fork check
}
package() {