aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbson
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-11-07 15:24:03 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-11-07 16:30:44 +0000
commitde60607904f7c020524e06d3168a24f903da6257 (patch)
treec09abf4fd8977f8fc3634876b49b4520cf85c2ad /testing/libbson
parent60ccd5b05a7fccfc935132fab1ab48f6835f285b (diff)
downloadaports-de60607904f7c020524e06d3168a24f903da6257.tar.bz2
aports-de60607904f7c020524e06d3168a24f903da6257.tar.xz
testing/libbson: new aport
library providing useful routines related to building, parsing, and iterating BSON documents
Diffstat (limited to 'testing/libbson')
-rw-r--r--testing/libbson/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/libbson/APKBUILD b/testing/libbson/APKBUILD
new file mode 100644
index 0000000000..6d944b8ce6
--- /dev/null
+++ b/testing/libbson/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=libbson
+pkgver=1.3.6
+pkgrel=0
+pkgdesc="routines related to building, parsing, and iterating BSON documents"
+url="https://github.com/mongodb/libbson"
+arch="all"
+license="Apache2"
+depends=
+depends_dev=
+makedepends="$depends_dev autoconf automake libtool"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/libbson/archive/$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="5d79d5504a05d5a4cd952062e73ac781 libbson-1.3.6.tar.gz"
+sha256sums="13f3358acf71e4d52bc006d68c7dcfb28a410e4f9b24470d9935ec8eed37fcd3 libbson-1.3.6.tar.gz"
+sha512sums="cf6fb3e95b0bc49517190ebbf8592e57934866510c4f00ac04406f013ebca4873d3f615d98b4e36437f8b676f0434209d7321e45e5d131e144d294031f06cc59 libbson-1.3.6.tar.gz"