aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libcypher-parser
diff options
context:
space:
mode:
authorChris Leishman <chris@leishman.org>2017-11-13 23:02:11 -0500
committerTimo Teräs <timo.teras@iki.fi>2018-02-06 16:04:14 +0000
commit329d226ef40efca85df2a038c76d15c5b62a3c74 (patch)
tree608d8afb0dba2b97bab7d2e91d01913a13b1c9e0 /testing/libcypher-parser
parentbb57af58ec98fe355a2c990eebd8125c710d9839 (diff)
downloadaports-329d226ef40efca85df2a038c76d15c5b62a3c74.tar.bz2
aports-329d226ef40efca85df2a038c76d15c5b62a3c74.tar.xz
testing/libcypher-parser: update to version 0.6.0
Diffstat (limited to 'testing/libcypher-parser')
-rw-r--r--testing/libcypher-parser/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/testing/libcypher-parser/APKBUILD b/testing/libcypher-parser/APKBUILD
index dfed1492e4..79be7fc4e7 100644
--- a/testing/libcypher-parser/APKBUILD
+++ b/testing/libcypher-parser/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Chris Leishman <chris@leishman.org>
# Maintainer: Chris Leishman <chris@leishman.org>
pkgname=libcypher-parser
-pkgver=0.5.1
+pkgver=0.6.0
pkgrel=0
pkgdesc="Parsing library for the Cypher query language"
url="https://github.com/cleishm/libcypher-parser"
@@ -11,7 +11,7 @@ depends=""
depends_dev=""
makedepends="$depends_dev automake autoconf libtool check-dev doxygen pkgconfig"
install=""
-subpackages="$pkgname-dev $pkgname-doc cypher-lint cypher-lint-doc"
+subpackages="$pkgname-dev $pkgname-doc::noarch cypher-lint cypher-lint-doc::noarch"
source="https://github.com/cleishm/libcypher-parser/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/"$pkgname-$pkgver"
@@ -21,10 +21,14 @@ build() {
--prefix=/usr \
|| return 1
make || return 1
- make check || return 1
make doc || return 1
}
+check() {
+ cd "$_builddir"
+ make check || return 1
+}
+
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
@@ -35,13 +39,12 @@ package() {
doc() {
depends="$depends_doc"
pkgdesc="$pkgdesc (documentation)"
- arch=${arch_doc:-"noarch"}
install_if="docs $pkgname=$pkgver-r$pkgrel"
- if [ "X$subpkgname" = "Xlibcypher-parser-doc" ]; then
+ if [ "$subpkgname" = "libcypher-parser-doc" ]; then
mkdir -p "$subpkgdir"/usr/share
mv "$pkgdir"/usr/share/doc "$subpkgdir"/usr/share/
- elif [ "X$subpkgname" = "Xcypher-lint-doc" ]; then
+ elif [ "$subpkgname" = "cypher-lint-doc" ]; then
mkdir -p "$subpkgdir"/usr/share
mv "$pkgdir"/usr/share/man "$subpkgdir"/usr/share/
find "$subpkgdir"/usr/share/man/ -type f | xargs gzip -9
@@ -50,7 +53,7 @@ doc() {
fi
# remove if empty, ignore error (not empty)
- rmdir -f "$pkgdir"/usr/share "$pkgdir"/usr || true 2>/dev/null
+ rmdir "$pkgdir"/usr/share "$pkgdir"/usr || true 2>/dev/null
return 0
}
@@ -64,6 +67,5 @@ lint() {
rmdir "$pkgdir"/usr/bin "$pkgdir"/usr || true 2>/dev/null
return 0
}
-md5sums="c4c9a3bd9a97f4d97c1ffeb1ff19ebbe libcypher-parser-0.5.1.tar.gz"
-sha256sums="bc9e3234e97b2e7c5829bfe17ed9e2f6a619a2e66144b6db7a6082e697441ead libcypher-parser-0.5.1.tar.gz"
-sha512sums="632d65741332cc81cb42bbf61f53074677d81db27b6a8f2ce9f44fa04f82f16fd13b78c1ed34518124f7e10b77dc87fa3d4f791d19e076c6dc668b89faa82a56 libcypher-parser-0.5.1.tar.gz"
+
+sha512sums="5faabbfe09a98ad5805a533dfdf1ba3e3357d4320a274242472ef27fc3696d48a4b0bad1606ab6092aae111fc1d7f7c9c3fa875433d6c94bc1e03f2428ca889e libcypher-parser-0.6.0.tar.gz"