aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libimobiledevice/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-01-10 12:09:42 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-01-10 12:09:42 +0000
commit5e3a5ea6d0bbec8e109bd5b51ed30c3c77e00e12 (patch)
tree2ffc8d4473baf216c7695f3776d0a448220f1e2c /testing/libimobiledevice/APKBUILD
parent476e3abbb302e91070fc403f30b6c563681ff335 (diff)
downloadaports-5e3a5ea6d0bbec8e109bd5b51ed30c3c77e00e12.tar.bz2
aports-5e3a5ea6d0bbec8e109bd5b51ed30c3c77e00e12.tar.xz
testing/libimobiledevice: new aport
Diffstat (limited to 'testing/libimobiledevice/APKBUILD')
-rw-r--r--testing/libimobiledevice/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/libimobiledevice/APKBUILD b/testing/libimobiledevice/APKBUILD
new file mode 100644
index 0000000000..1fc0fdc8bf
--- /dev/null
+++ b/testing/libimobiledevice/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libimobiledevice
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
+url="http://libimobiledevice.org/"
+arch="all"
+license="GPL2 LGPL2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev gnutls-dev openssl-dev libgcrypt-dev
+ libusbmuxd-dev libtasn1-dev pkgconfig libtool
+ automake autoconf "
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --with-cython
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="8757900ba7bbe2ef5f54342415d0223e libimobiledevice-1.2.0.tar.bz2"
+sha256sums="786b0de0875053bf61b5531a86ae8119e320edab724fc62fe2150cc931f11037 libimobiledevice-1.2.0.tar.bz2"
+sha512sums="0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589 libimobiledevice-1.2.0.tar.bz2"