aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libmhash
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-09-22 10:17:40 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-09-22 10:21:11 +0000
commit3b11d3e83dc608d0508484cf6b72fb6cf1500f8c (patch)
treed13cbfd5e26f4302b2f008591b46a8d1b7f8e4b7 /testing/libmhash
parentc58776022367c8881218efed8ee032a91cd17e06 (diff)
downloadaports-3b11d3e83dc608d0508484cf6b72fb6cf1500f8c.tar.bz2
aports-3b11d3e83dc608d0508484cf6b72fb6cf1500f8c.tar.xz
testing/libmhash: fixed bool declaration with musl
Diffstat (limited to 'testing/libmhash')
-rw-r--r--testing/libmhash/APKBUILD14
-rw-r--r--testing/libmhash/musl-fix-bool-includes.patch17
2 files changed, 26 insertions, 5 deletions
diff --git a/testing/libmhash/APKBUILD b/testing/libmhash/APKBUILD
index b35e8dce81..8b06a46553 100644
--- a/testing/libmhash/APKBUILD
+++ b/testing/libmhash/APKBUILD
@@ -3,7 +3,7 @@
pkgname=libmhash
_pkgname=mhash
pkgver=0.9.9.9
-pkgrel=0
+pkgrel=1
pkgdesc="Library which provides a uniform interface to a large number of hash algorithms"
url="http://mhash.sourceforge.net/"
arch="all"
@@ -12,7 +12,8 @@ depends=""
makedepends=""
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://sourceforge.net/projects/$_pkgname/files/$_pkgname/$pkgver/$_pkgname-$pkgver.tar.gz/download"
+source="$pkgname-$pkgver.tar.gz::https://sourceforge.net/projects/$_pkgname/files/$_pkgname/$pkgver/$_pkgname-$pkgver.tar.gz/downloadi
+musl-fix-bool-includes.patch"
builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
@@ -31,6 +32,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="ee66b7d5947deb760aeff3f028e27d25 libmhash-0.9.9.9.tar.gz"
-sha256sums="3dcad09a63b6f1f634e64168dd398e9feb9925560f9b671ce52283a79604d13e libmhash-0.9.9.9.tar.gz"
-sha512sums="82ad8b8e9b0463c5a14f5c0e572badc42c4697bac5505443b144287b3f8510b1410721b4277f092a0d6045c4342e997831011cdfcbfa8f1dae6edd5d9e3cefee libmhash-0.9.9.9.tar.gz"
+md5sums="ee66b7d5947deb760aeff3f028e27d25 libmhash-0.9.9.9.tar.gz
+430f0e1e56344d71effd49dc493c67ac musl-fix-bool-includes.patch"
+sha256sums="3dcad09a63b6f1f634e64168dd398e9feb9925560f9b671ce52283a79604d13e libmhash-0.9.9.9.tar.gz
+38be515c882560d714ea6c7ba7dd258d38feb4aaeb2d06743893736d78d51b50 musl-fix-bool-includes.patch"
+sha512sums="82ad8b8e9b0463c5a14f5c0e572badc42c4697bac5505443b144287b3f8510b1410721b4277f092a0d6045c4342e997831011cdfcbfa8f1dae6edd5d9e3cefee libmhash-0.9.9.9.tar.gz
+848c687be7da956884b287ecf57d445c974db9421d1e3a6648837aa18ebe86ace1366e0863ba62a898010b56c85ffd2f8294aaa7744ed31cfcec67b0021cc731 musl-fix-bool-includes.patch"
diff --git a/testing/libmhash/musl-fix-bool-includes.patch b/testing/libmhash/musl-fix-bool-includes.patch
new file mode 100644
index 0000000000..d27b5c02bf
--- /dev/null
+++ b/testing/libmhash/musl-fix-bool-includes.patch
@@ -0,0 +1,17 @@
+diff --git a/include/mutils/mutils.h b/include/mutils/mutils.h
+index 2712a33..a28ac98 100644
+--- a/include/mutils/mutils.h
++++ b/include/mutils/mutils.h
+@@ -21,6 +21,12 @@
+ #if !defined(__MUTILS_H)
+ #define __MUTILS_H
+
++// Added to satisfy OS X
++#if !defined(_Bool)
++#define _Bool bool
++#endif
++// End custom addition
++
+ #include <mutils/mincludes.h>
+
+ #if defined(const)