aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libspiro
diff options
context:
space:
mode:
authorEd Robinson <ed.robinson@reevoo.com>2017-10-09 20:13:22 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-11 09:59:52 +0000
commit4c293b345ec917916f5b6cc54289ee3469006468 (patch)
tree5f2076ebb154de41d235c4e51fabad9542ae3756 /testing/libspiro
parent20dd767b4607bc0a5b0254c866147f9b4634a052 (diff)
downloadaports-4c293b345ec917916f5b6cc54289ee3469006468.tar.bz2
aports-4c293b345ec917916f5b6cc54289ee3469006468.tar.xz
testing/libspiro: new aport
Diffstat (limited to 'testing/libspiro')
-rw-r--r--testing/libspiro/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/libspiro/APKBUILD b/testing/libspiro/APKBUILD
new file mode 100644
index 0000000000..7c74f960b8
--- /dev/null
+++ b/testing/libspiro/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Ed Robinson <ed@reevoo.com>
+# Maintainer: Ed Robinson <ed@reevoo.com>
+pkgname=libspiro
+pkgver=0.5.20150702
+pkgrel=0
+pkgdesc="Spiro is the creation of Raph Levien. It simplifies the drawing of beautiful curves."
+url="https://github.com/fontforge/libspiro"
+arch="all"
+license="GPLv3"
+source="https://github.com/fontforge/$pkgname/releases/download/$pkgver/$pkgname-dist-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ autoreconf -i
+ automake --foreign -Wall
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="ae09915b2738cc2448df2cb00831e65fa45e887a7af9631d7361f5d2fca0b800588ea1d7c74c42e0e250835f3a322e64d44a7b18b2fd6641ac61e6adc1f03da8 libspiro-dist-0.5.20150702.tar.gz"