aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libtickit
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-17 10:12:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-19 13:47:20 +0000
commitb8542ece9fcd528fe1456553731e6576d1894a3b (patch)
tree14c80c07fe42f55b24f1ddb0ea05fb490b191e41 /testing/libtickit
parent9221d622d8306d00f3a9d1915388ef5b9dc272e5 (diff)
downloadaports-b8542ece9fcd528fe1456553731e6576d1894a3b.tar.bz2
aports-b8542ece9fcd528fe1456553731e6576d1894a3b.tar.xz
testing/libtickit: new aport
Disabled tests for now, seems they are passing but in the end they failed with error: t/15term-input.t (Wstat: 9 Tests: 29 Failed: 0) Non-zero wait status: 9 Parse errors: No plan found in TAP output See bug: https://bugs.launchpad.net/libtickit/+bug/1756523
Diffstat (limited to 'testing/libtickit')
-rw-r--r--testing/libtickit/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/libtickit/APKBUILD b/testing/libtickit/APKBUILD
new file mode 100644
index 0000000000..238403ba98
--- /dev/null
+++ b/testing/libtickit/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=libtickit
+pkgver=0.2
+pkgrel=0
+pkgdesc="A library that provides an abstracted mechanism for building interactive full-screen terminal programs"
+url="http://www.leonerd.org.uk/code/libtickit/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libtermkey-dev"
+checkdepends="perl-test-harness-utils"
+# See https://bugs.launchpad.net/libtickit/+bug/1756523
+options="!check" #FIXME: some tests are failing
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.leonerd.org.uk/code/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ sed -i -e "s/PREFIX=\/usr\/local/PREFIX=\/usr/g" Makefile
+}
+build() {
+ cd "$builddir"
+ make PREFIX=/usr
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="5ba8581dfc17d0f56fc9e543aa452980ce864a5079a34d60db3a15b49c82c894ce082598865aeaa28c32c32549c40582fb40d1209ea893c8c6993604cae9437b libtickit-0.2.tar.gz"