aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libu2f-host
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-02 17:02:21 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-02 17:02:33 +0100
commitc2c6b18e6602a8abcc9a63e02accee4570b26550 (patch)
tree53faae263d8a78b1c0772c2da6dc35fb5279e011 /testing/libu2f-host
parentdb34bf46f114128e9b624e06cf08c145c7747dc2 (diff)
downloadaports-c2c6b18e6602a8abcc9a63e02accee4570b26550.tar.bz2
aports-c2c6b18e6602a8abcc9a63e02accee4570b26550.tar.xz
testing/libu2f-host: new aport
https://developers.yubico.com/libu2f-host/ Yubico Universal 2nd Factor (U2F) Host C Library
Diffstat (limited to 'testing/libu2f-host')
-rw-r--r--testing/libu2f-host/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/libu2f-host/APKBUILD b/testing/libu2f-host/APKBUILD
new file mode 100644
index 0000000000..d91b62210e
--- /dev/null
+++ b/testing/libu2f-host/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=libu2f-host
+pkgver=1.1.4
+pkgrel=0
+pkgdesc="Yubico Universal 2nd Factor (U2F) Host C Library"
+url="https://developers.yubico.com/libu2f-host/"
+arch="all"
+license="GPL-3.0-or-later LGPL-2.0-or-later"
+makedepends="hidapi-dev json-c-dev linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://developers.yubico.com/$pkgname/Releases/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ed411d83b6fad734dad48e5fb6ab72d5990e91bbf73a2121d7e9008c08d3f34f9b17cf4a951a91e01f33e8fba163c260ca5c944120822992a1ee1d1050bd5249 libu2f-host-1.1.4.tar.xz"