aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libuser
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 13:23:55 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 13:24:39 +0000
commit046ea077c13ac73c895db3922eeff71a031f0775 (patch)
tree9edf0755204ede0007f5b80218d1938f87c7b7fc /testing/libuser
parent79af21f75abc0a58db04f803a5615d92e33676b0 (diff)
downloadaports-046ea077c13ac73c895db3922eeff71a031f0775.tar.bz2
aports-046ea077c13ac73c895db3922eeff71a031f0775.tar.xz
testing/libuser: new aport
Diffstat (limited to 'testing/libuser')
-rw-r--r--testing/libuser/0001-Check-for-issetugid.patch62
-rw-r--r--testing/libuser/0002-remove-unused-execinfo.h.patch27
-rw-r--r--testing/libuser/APKBUILD53
3 files changed, 142 insertions, 0 deletions
diff --git a/testing/libuser/0001-Check-for-issetugid.patch b/testing/libuser/0001-Check-for-issetugid.patch
new file mode 100644
index 0000000000..79756b9a07
--- /dev/null
+++ b/testing/libuser/0001-Check-for-issetugid.patch
@@ -0,0 +1,62 @@
+From d0537cb7f2dc5877700ad78dfd191515379d4edc Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 7 Jan 2016 02:22:51 +0000
+Subject: [PATCH 1/2] Check for issetugid()
+
+If secure version of getenv is not there then we can use
+issetugid() as aid to call getenv()
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ configure.ac | 1 +
+ lib/config.c | 12 +++++++++++-
+ 2 files changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1ded1a2..ee19e1f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -125,6 +125,7 @@ AC_TYPE_OFF_T
+ AC_TYPE_SIZE_T
+
+ AC_CHECK_FUNCS([__secure_getenv secure_getenv])
++AC_CHECK_FUNCS([issetugid])
+
+ # Modify CFLAGS after all tests are run (some of them could fail because
+ # of the -Werror).
+diff --git a/lib/config.c b/lib/config.c
+index 29e7120..30f9daf 100644
+--- a/lib/config.c
++++ b/lib/config.c
+@@ -44,8 +44,10 @@
+ # define safe_getenv(string) secure_getenv(string)
+ #elif defined(HAVE___SECURE_GETENV)
+ # define safe_getenv(string) __secure_getenv(string)
++#elif defined(HAVE_ISSETUGID)
++# define safe_getenv(string) safe_getenv_issetugid(string)
+ #else
+-# error Neither secure_getenv not __secure_getenv are available
++# error None of secure_getenv, __secure_getenv, or issetugid is available
+ #endif
+
+ struct config_config {
+@@ -59,6 +61,14 @@ struct config_key {
+ GList *values;
+ };
+
++static const char*
++safe_getenv_issetugid(const char* name)
++{
++ if (issetugid ())
++ return 0;
++ return getenv (name);
++}
++
+ /* Compare two section names */
+ static int
+ compare_section_names(gconstpointer a, gconstpointer b)
+--
+2.7.0
+
diff --git a/testing/libuser/0002-remove-unused-execinfo.h.patch b/testing/libuser/0002-remove-unused-execinfo.h.patch
new file mode 100644
index 0000000000..4bc0219f19
--- /dev/null
+++ b/testing/libuser/0002-remove-unused-execinfo.h.patch
@@ -0,0 +1,27 @@
+From 4b2f81f307ffeac12956e5c16e894e5ebb937ea5 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 7 Jan 2016 02:26:00 +0000
+Subject: [PATCH 2/2] remove unused execinfo.h
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ lib/error.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/lib/error.c b/lib/error.c
+index a5ec30a..443e601 100644
+--- a/lib/error.c
++++ b/lib/error.c
+@@ -18,7 +18,6 @@
+ #include <config.h>
+ #include <sys/types.h>
+ #include <errno.h>
+-#include <execinfo.h>
+ #include <libintl.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
+--
+2.7.0
+
diff --git a/testing/libuser/APKBUILD b/testing/libuser/APKBUILD
new file mode 100644
index 0000000000..cdacfe5b81
--- /dev/null
+++ b/testing/libuser/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libuser
+pkgver=0.62
+pkgrel=0
+pkgdesc="A standardized interface for manipulating and administering user and group accounts"
+url="https://fedorahosted.org/libuser"
+arch="all"
+license="LGPL"
+depends="python2"
+makedepends="python2-dev glib-dev popt-dev libexecinfo-dev linux-pam-dev
+autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py2-$pkgname:_py"
+source="https://fedorahosted.org/releases/l/i/$pkgname/$pkgname-$pkgver.tar.xz
+0001-Check-for-issetugid.patch
+0002-remove-unused-execinfo.h.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --with-python \
+ --disable-gtk-doc-html \
+ --disable-rpath
+ sed -i 's/SUBDIRS = po docs/SUBDIRS = po/' Makefile
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+_py() {
+ cd "$builddir"
+ pkgdesc="Python2 bindings for $pkgname"
+ depends="$pkgname"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir""/usr/lib/python2.7" "$subpkgdir"/usr/lib
+}
+
+md5sums="63e5e5c551e99dc5302b40b80bd6d4f2 libuser-0.62.tar.xz
+867b1b35a9c029f935a4da70b3f41722 0001-Check-for-issetugid.patch
+0b2fef5a319978f6428e14866fd2bd2d 0002-remove-unused-execinfo.h.patch"
+sha256sums="a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b libuser-0.62.tar.xz
+da99b8200a6e5b23fb288262300cefcfc4e16a1577cdb617aff8a4d4a19550c5 0001-Check-for-issetugid.patch
+facbdb7d01ce05f0eea539dba5379b1ca0976b226ef3962d567832966d01ce4f 0002-remove-unused-execinfo.h.patch"
+sha512sums="bc2f68456eae5912ac236192e97a3d66d5fa782520eff48d44d391c1ade590e001d821d7a93499e2391d0310cf03f60e4411f045f6ee3301af4e174d9ddc8450 libuser-0.62.tar.xz
+544f5124bf9a78daa99cf6d3f5b89c8519d7385aa7d1da9384fe29fea7285e61d7c91a865303258669232c3ed0590c8143e8acad66a6e1bc87069444e4af40b1 0001-Check-for-issetugid.patch
+b7da24da834b7e00e3449ab49c2187b0d8993079888b0900b62ec418db8fc025a22ee4b779715cc6ca327b614d97dd1fbf0a33f4f22fedade06782a3ba11f599 0002-remove-unused-execinfo.h.patch"