aboutsummaryrefslogtreecommitdiffstats
path: root/testing/livestreamer
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-04 00:58:32 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-04 00:58:32 +0000
commited3bd45a71cc62cb387d86a24e747db652b99021 (patch)
tree4de9f39c3a2ad117fe6ab4a6bbf6668e9d4923c0 /testing/livestreamer
parentb28978415c266263c886aa4331e7835bd15a61cb (diff)
downloadaports-ed3bd45a71cc62cb387d86a24e747db652b99021.tar.bz2
aports-ed3bd45a71cc62cb387d86a24e747db652b99021.tar.xz
testing/livestreamer: modernize and fix typo in description
Diffstat (limited to 'testing/livestreamer')
-rw-r--r--testing/livestreamer/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/testing/livestreamer/APKBUILD b/testing/livestreamer/APKBUILD
index 634be31bfa..7a36201c82 100644
--- a/testing/livestreamer/APKBUILD
+++ b/testing/livestreamer/APKBUILD
@@ -2,23 +2,24 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=livestreamer
pkgver=1.12.2
-pkgrel=1
-pkgdesc="ommand-line utility that extracts streams from various services and pipes them into a video player of choice"
-url=" http://livestreamer.io/"
+pkgrel=2
+pkgdesc="Command-line utility that extracts streams from various services and pipes them into a video player of choice"
+url="http://livestreamer.io/"
arch="noarch"
license="BSD"
-depends="py-requests rtmpdump py-setuptools py-singledispatch py-futures
- py-six py-crypto py-librtmp"
-depends_dev=""
-makedepends="$depends_dev py-sphinx"
-install=""
-subpackages=""
+depends="py-requests rtmpdump py-setuptools py-singledispatch py-futures py-six py-crypto py-librtmp"
+makedepends="py-sphinx"
source="$pkgname-$pkgver.tar.gz::https://github.com/chrippa/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
python2 setup.py test
}
@@ -28,6 +29,4 @@ package() {
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-md5sums="1d896f85f27d28f84a962e9cf548c409 livestreamer-1.12.2.tar.gz"
-sha256sums="4d6e2954abff198dce082f34a19a54dbf6fb95ca53567d92a661e527fe68e3ba livestreamer-1.12.2.tar.gz"
sha512sums="547886b494a7562e479cf31db15b5b02545f2ebc5f8b70d0fe0006d3748c5c9f20517638c7642377e2bdc4083738829eacf272e8d68f332da212bf65300f5d12 livestreamer-1.12.2.tar.gz"