aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lksctp-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-25 06:27:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-25 06:30:29 +0000
commit661e75605c46626dc05673e0127908346133105f (patch)
treef4447a38adcbf7ebbd725370c5a33592723b9b87 /testing/lksctp-tools
parente4d1db2e00c8fbec0229a8eb4ba1f44503ad8375 (diff)
downloadaports-661e75605c46626dc05673e0127908346133105f.tar.bz2
aports-661e75605c46626dc05673e0127908346133105f.tar.xz
testing/lksctp-tools: new aport
User-space access to Linux Kernel SCTP http://lksctp.sourceforge.net
Diffstat (limited to 'testing/lksctp-tools')
-rw-r--r--testing/lksctp-tools/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/lksctp-tools/APKBUILD b/testing/lksctp-tools/APKBUILD
new file mode 100644
index 0000000000..2f489196e9
--- /dev/null
+++ b/testing/lksctp-tools/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor:
+# Maintainer:
+pkgname=lksctp-tools
+pkgver=1.0.14
+pkgrel=0
+pkgdesc="User-space access to Linux Kernel SCTP"
+url="http://lksctp.sourceforge.net"
+arch="all"
+license="GPLv2 and GPLv2+ and LGPLv2 and MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libtool automake autoconf"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/lksctp/lksctp-tools-$pkgver.tar.gz"
+
+_builddir="$srcdir"/lksctp-tools-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ if ! [ -e configure ]; then
+ ./bootstrap
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ || return 1
+ make
+
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/lksctp-tools/*.la
+}
+
+md5sums="12bc67f9b47ea631328a592ce7a53ca1 lksctp-tools-1.0.14.tar.gz"
+sha256sums="301294389709d3e19bc1c27e234df5aadef00e279345d19c92f596cf1f2e4110 lksctp-tools-1.0.14.tar.gz"
+sha512sums="d7ca2c17c85210020aa8247e03b3e733f168387d41c955aab3254bb03627725a54a773a924ceb6215dbe95630f698c409690e9b680e88e15779ce9a3bc11ddb7 lksctp-tools-1.0.14.tar.gz"