aboutsummaryrefslogtreecommitdiffstats
path: root/testing/luakit
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-09-16 13:31:55 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-09-16 13:32:12 +0200
commit95cc9f41b3b0451ba9e810b7b4d9486d8e4845cc (patch)
treedfb1b60c0ebfbcbd717dc8b69dae65d07c5900d4 /testing/luakit
parent27f9df01bd23e98c5519c2eb93c5dc584569dbbe (diff)
downloadaports-95cc9f41b3b0451ba9e810b7b4d9486d8e4845cc.tar.bz2
aports-95cc9f41b3b0451ba9e810b7b4d9486d8e4845cc.tar.xz
testing/luakit: don't build with -ggdb
Diffstat (limited to 'testing/luakit')
-rw-r--r--testing/luakit/APKBUILD8
-rw-r--r--testing/luakit/config-mk.patch12
2 files changed, 17 insertions, 3 deletions
diff --git a/testing/luakit/APKBUILD b/testing/luakit/APKBUILD
index 437736d7ad..0fb5de5f19 100644
--- a/testing/luakit/APKBUILD
+++ b/testing/luakit/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=luakit
pkgver=2017.08.10
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, small, webkit based browser framework extensible by Lua"
url="https://github.com/luakit/luakit"
arch="all"
@@ -12,7 +12,8 @@ depends_dev=""
makedepends="webkit2gtk-dev"
install=""
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz
+ config-mk.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -25,4 +26,5 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
-sha512sums="6cceb241ca5a7ad7dfbb3964888318b5f2c5f734175ea7ecd5178419d037d58dc5e0aba00a7ed8ca3dd811cc5af953c353b0cd203be95a15c6a78c396f9230c8 luakit-2017.08.10.tar.gz"
+sha512sums="6cceb241ca5a7ad7dfbb3964888318b5f2c5f734175ea7ecd5178419d037d58dc5e0aba00a7ed8ca3dd811cc5af953c353b0cd203be95a15c6a78c396f9230c8 luakit-2017.08.10.tar.gz
+d852a17bf202b18e75bda3885e421a957ce501ebbeb0ecd6e7a6379747e350878c9f95683a0385ce9daa719ddd02a3e5d5143ebd9ee892a469d8457e7a863b5a config-mk.patch"
diff --git a/testing/luakit/config-mk.patch b/testing/luakit/config-mk.patch
new file mode 100644
index 0000000000..59d407891f
--- /dev/null
+++ b/testing/luakit/config-mk.patch
@@ -0,0 +1,12 @@
+diff -upr luakit-2017.08.10.orig/config.mk luakit-2017.08.10/config.mk
+--- luakit-2017.08.10.orig/config.mk 2017-09-16 13:29:59.436651544 +0200
++++ luakit-2017.08.10/config.mk 2017-09-16 13:30:42.353527111 +0200
+@@ -2,7 +2,7 @@
+
+ # Compile/link options.
+ CC ?= gcc
+-CFLAGS += -std=gnu99 -ggdb -W -Wall -Wextra -Werror=unused-result
++CFLAGS += -std=gnu99 -W -Wall -Wextra -Werror=unused-result
+ LDFLAGS +=
+ CPPFLAGS +=
+