aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-02 10:43:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-02 10:45:32 +0000
commit8827ab5d758362a00f25e71caadfcbc00859c0ef (patch)
tree9ad41f2e8030d5755f0b5e4c9105da905c6a97c2 /testing/lxd
parent9492e48fbc49c1335add210c70c68214e2d81101 (diff)
downloadaports-8827ab5d758362a00f25e71caadfcbc00859c0ef.tar.bz2
aports-8827ab5d758362a00f25e71caadfcbc00859c0ef.tar.xz
testing/lxd: fix ppc64le build
On systems without glibc, you might lack definition of PATH_MAX. This patch adds the limits.h header to solve this issue.
Diffstat (limited to 'testing/lxd')
-rw-r--r--testing/lxd/APKBUILD2
-rw-r--r--testing/lxd/fix-ppc64le-build.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/testing/lxd/APKBUILD b/testing/lxd/APKBUILD
index 8d49f33122..ad9c24d1dd 100644
--- a/testing/lxd/APKBUILD
+++ b/testing/lxd/APKBUILD
@@ -13,6 +13,7 @@ install="$pkgname.pre-install"
options="!check"
source="https://linuxcontainers.org/downloads/$pkgname/$pkgname-$pkgver.tar.gz
lxd-dont-go-get.patch
+ fix-ppc64le-build.patch
$pkgname.confd
$pkgname.initd"
_project="github.com/lxc/lxd"
@@ -51,5 +52,6 @@ package() {
sha512sums="3f81c322f686a23afc5408403903b9349ccb29e607a1cfff2f48ebd83f4bed8dc618fb81d85c36fd6d84834a687a903af68f0213956c51ddba732d658ef09f8a lxd-3.0.0.tar.gz
e2c0c96d0efc33e459cf14365f01d60b73ed03f028d36ca5ea27cd647f5d2a91ec61bcf2723437f7b930aec6ebabac3697e0e3adc6b2918817833c9f182aab49 lxd-dont-go-get.patch
+13635b813c817ab503245203c97ed68130fde7254a0b17addd4fdc2bb0662d2d4a96db0efeed16dad540d5090cf186b83a9ca4d84610402634f38d1d25d5f933 fix-ppc64le-build.patch
bc32c71f2ce10f508433e1e4651c08c18e8a17e9419a7ce391c0f127fc7cf378c665178926b35eae8813e290d9c5eab3ceb605679fd32efdf2cf98a57cee4127 lxd.confd
94de0c0d5ab63463a929a4151359950b1117d0ada5ccf0944311cc70c6b6d4c437ccb4158734ab35db67bfb4abc437074c3f3515be4531f63adc74da21fefb5b lxd.initd"
diff --git a/testing/lxd/fix-ppc64le-build.patch b/testing/lxd/fix-ppc64le-build.patch
new file mode 100644
index 0000000000..1bebfd1a9e
--- /dev/null
+++ b/testing/lxd/fix-ppc64le-build.patch
@@ -0,0 +1,10 @@
+--- a/dist/src/github.com/lxc/lxd/lxd/main_forkfile.go
++++ b/dist/src/github.com/lxc/lxd/lxd/main_forkfile.go
+@@ -17,6 +17,7 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <limits.h>
+
+ extern char* advance_arg(bool required);
+ extern void error(char *msg);