aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mbuffer
diff options
context:
space:
mode:
authorFusl <root@hallowe.lt>2018-01-09 13:11:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-27 01:52:42 +0000
commit2b7ad76703deec43b91873e627ffea328b623dea (patch)
treeba121804869d64ad0fdcb601f4ef22feb829e336 /testing/mbuffer
parentcb3a0a912d97057a8f97126e9b14e48c9e4f4f31 (diff)
downloadaports-2b7ad76703deec43b91873e627ffea328b623dea.tar.bz2
aports-2b7ad76703deec43b91873e627ffea328b623dea.tar.xz
testing/mbuffer: initial package commit based on version 20171011
Diffstat (limited to 'testing/mbuffer')
-rw-r--r--testing/mbuffer/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/mbuffer/APKBUILD b/testing/mbuffer/APKBUILD
new file mode 100644
index 0000000000..719ed28be9
--- /dev/null
+++ b/testing/mbuffer/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Katie Holly <holly@fuslvz.ws>
+# Maintainer: Katie Holly <holly@fuslvz.ws>
+pkgname=mbuffer
+pkgver=20171011
+pkgrel=0
+pkgdesc="mbuffer buffers I/O operations and displays the throughput rate"
+url="http://www.maier-komor.de/mbuffer.html"
+arch="all"
+license="GPL-3.0"
+depends=""
+makedepends="linux-headers libressl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="
+ http://www.maier-komor.de/software/mbuffer/mbuffer-$pkgver.tgz
+ "
+
+builddir="$srcdir"/mbuffer-$pkgver
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="398d7545388a94b4f8961193192cd5e1139b84f31c7699c2b7f66b84a40488a2e70c88a2a70578bd95375e11efc87978a5f6fec805dbbc5f1fea460b3a9c68c4 mbuffer-20171011.tgz"