aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mbuffer
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-19 23:47:54 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-16 19:20:21 +0000
commit5a8b5e88e3f647122e996fa8e119927a9469e13e (patch)
treee605e3629cf1186139705a247187c4d43d2f0f87 /testing/mbuffer
parent2b64d7d10402d1e4a7e9d52ed46cdcf172021277 (diff)
downloadaports-5a8b5e88e3f647122e996fa8e119927a9469e13e.tar.bz2
aports-5a8b5e88e3f647122e996fa8e119927a9469e13e.tar.xz
Initial APKBUILD for mbuffer
Package description: mbuffer is a tool for buffering data streams with a large set of unique features: - direct support for TCP based network targets (IPv4 and IPv6) - ability to send to multiple targets in parallel (distribution mode) - support for multiple volumes - I/O rate limitation - high/low watermark based restart criteria - configurable buffer size - on the fly MD5 hash calculation - highly efficient, multi-threaded implementation Website: http://www.maier-komor.de/mbuffer.html
Diffstat (limited to 'testing/mbuffer')
-rw-r--r--testing/mbuffer/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/mbuffer/APKBUILD b/testing/mbuffer/APKBUILD
new file mode 100644
index 0000000000..f5ef988a55
--- /dev/null
+++ b/testing/mbuffer/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=mbuffer
+pkgver=20110724
+pkgrel=0
+pkgdesc="Measuring Buffer is an enhanced version of buffer"
+url="http://www.maier-komor.de/mbuffer.html"
+arch="all"
+license="GPL3+"
+depends=""
+depends_dev=""
+makedepends="mt-st mhash-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.maier-komor.de/software/mbuffer/$pkgname-$pkgver.tgz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="fc183b787f33011b42c9814029c69054 mbuffer-20110724.tgz"