aboutsummaryrefslogtreecommitdiffstats
path: root/testing/moe
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-06-30 19:37:23 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-03 12:30:40 +0000
commitf02818be917a65fc78a2edb9493719172beddc56 (patch)
tree8cb504f806a4546d2e1a3b5f923cd017ba7721c0 /testing/moe
parentd4067bd4c8665e089daa1544ecf3ae332baad401 (diff)
downloadaports-f02818be917a65fc78a2edb9493719172beddc56.tar.bz2
aports-f02818be917a65fc78a2edb9493719172beddc56.tar.xz
testing/moe: new aport
Diffstat (limited to 'testing/moe')
-rw-r--r--testing/moe/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/moe/APKBUILD b/testing/moe/APKBUILD
new file mode 100644
index 0000000000..11f61c56f2
--- /dev/null
+++ b/testing/moe/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=moe
+pkgver=1.9
+pkgrel=0
+pkgdesc="A powerful and user-friendly text editor"
+url="https://www.gnu.org/software/moe/moe.html"
+arch="all"
+license="GPL"
+makedepends="ncurses-dev texinfo"
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/gnu/moe/moe-$pkgver.tar.lz"
+options="!check"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="277700e4a796e1a7aee42de55ba4599a350a612f95a1a2eca5078d85f6f9a7db190fb5611eb2f286c98580af847a2934bf38a4bce10176db4c5cddc2d257f929 moe-1.9.tar.lz"