aboutsummaryrefslogtreecommitdiffstats
path: root/testing/moka-icon-theme
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-10-19 22:50:11 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-10-19 22:50:11 +0200
commit2399a012f30a2cb2bf9afbce31d88d96893a4ced (patch)
tree9723f33a296e67e0f5eed9d916036a3f5c5bb70f /testing/moka-icon-theme
parent8e65ab100036918d2160b4861bd52783620e54dc (diff)
downloadaports-2399a012f30a2cb2bf9afbce31d88d96893a4ced.tar.bz2
aports-2399a012f30a2cb2bf9afbce31d88d96893a4ced.tar.xz
testing/moka-icon-theme: new aport
Diffstat (limited to 'testing/moka-icon-theme')
-rw-r--r--testing/moka-icon-theme/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/moka-icon-theme/APKBUILD b/testing/moka-icon-theme/APKBUILD
new file mode 100644
index 0000000000..795e27229f
--- /dev/null
+++ b/testing/moka-icon-theme/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=moka-icon-theme
+pkgver=5.3.5
+pkgrel=0
+pkgdesc="Moka Icon Theme"
+url="http://snwh.org/moka"
+arch="noarch"
+license="CC-BY-SA-4.0"
+depends=""
+makedepends="automake autoconf libtool"
+install=""
+subpackages=""
+options="!strip"
+source="moka-icon-theme-$pkgver.tar.gz::https://github.com/snwh/moka-icon-theme/archive/v$pkgver.tar.gz"
+builddir="$srcdir/moka-icon-theme-$pkgver"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e52fb3c39bae53f547e61dd92bebf173 moka-icon-theme-5.3.5.tar.gz"
+sha256sums="91d1d702501fca85b7c8dedbc690884d697e482b732cd3801febd5f7c0525918 moka-icon-theme-5.3.5.tar.gz"
+sha512sums="81be63f0fe4b47eb70ca63681b40053c8facb7277d5df34212592a1fc7c349679508551e6ff67123127d372e88f61062ce59dd9c8ed6aaa02b49ef9e884e2b07 moka-icon-theme-5.3.5.tar.gz"