aboutsummaryrefslogtreecommitdiffstats
path: root/testing/monetdb
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-05 13:24:39 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-05 13:25:04 +0000
commit10b492044d9db302390ff04a524117ddaf3f4975 (patch)
tree5eb03718763c0e2f846b1f568984d1ece45532ad /testing/monetdb
parent9766a34cf909566fa41518f09a1b4083a206cea8 (diff)
downloadaports-10b492044d9db302390ff04a524117ddaf3f4975.tar.bz2
aports-10b492044d9db302390ff04a524117ddaf3f4975.tar.xz
testing/monetdb: new aport (fixes #8001)
Column-oriented database management system
Diffstat (limited to 'testing/monetdb')
-rw-r--r--testing/monetdb/APKBUILD37
-rw-r--r--testing/monetdb/fix-definitions-musl.patch17
2 files changed, 54 insertions, 0 deletions
diff --git a/testing/monetdb/APKBUILD b/testing/monetdb/APKBUILD
new file mode 100644
index 0000000000..644156bb50
--- /dev/null
+++ b/testing/monetdb/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=monetdb
+_pkgname=MonetDB
+pkgver=11.27.5
+pkgrel=0
+pkgdesc="Column-oriented database management system"
+url="https://www.monetdb.org/Home"
+arch="all"
+license="MPL-1.1"
+makedepends="musl-dev gcc bison make python libressl-dev libxml2-dev xz-dev bzip2-dev lz4-dev readline-dev snappy-dev curl-dev pcre-dev unixodbc-dev libatomic_ops-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.monetdb.org/downloads/sources/Jul2017-SP1/$_pkgname-$pkgver.tar.xz
+ fix-definitions-musl.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8e5ea7e010a3e336a2524ff63d0a0f9075cdaa290446dc87ee084701482fcce1c1e6069070af1cca438e43815fd238dc7486859c5a74b211651dee25a9c79459 MonetDB-11.27.5.tar.xz
+c705b33fecfdfc503621960bccf0bd03af66e9c2d213538daf8e59c2c351c6f98ddfd7325df6036d3de71d156953a21d19c10cbadd4a8b8de63297bdc1d86198 fix-definitions-musl.patch"
diff --git a/testing/monetdb/fix-definitions-musl.patch b/testing/monetdb/fix-definitions-musl.patch
new file mode 100644
index 0000000000..f8c3095aef
--- /dev/null
+++ b/testing/monetdb/fix-definitions-musl.patch
@@ -0,0 +1,17 @@
+--- a/tools/merovingian/daemon/merovingian.c
++++ b/tools/merovingian/daemon/merovingian.c
+@@ -87,6 +87,14 @@
+ #define F_DUPFD_CLOEXEC F_DUPFD
+ #endif
+
++#ifndef S_IRWXO
++#define S_IRWXO 0007
++#endif
++
++#ifndef S_IRWXG
++#define S_IRWXG 0070
++#endif
++
+
+ /* private structs */
+