aboutsummaryrefslogtreecommitdiffstats
path: root/testing/moreutils
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-04-10 17:17:28 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-04-10 17:17:28 +0000
commite665f33f238191c7fb6f91575c44476d75cb0ad2 (patch)
tree1488cf35e33eb0b58f38b769923d7387a1fcf8de /testing/moreutils
parentc37d17a898494845ae2ae1aefbd452c11269341c (diff)
downloadaports-e665f33f238191c7fb6f91575c44476d75cb0ad2.tar.bz2
aports-e665f33f238191c7fb6f91575c44476d75cb0ad2.tar.xz
testing/moreutils: added check()
Diffstat (limited to 'testing/moreutils')
-rw-r--r--testing/moreutils/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/testing/moreutils/APKBUILD b/testing/moreutils/APKBUILD
index cc3225e8f0..f15e795517 100644
--- a/testing/moreutils/APKBUILD
+++ b/testing/moreutils/APKBUILD
@@ -8,6 +8,7 @@ url="http://joeyh.name/code/moreutils/"
arch="all"
license="GPL-2.0-or-later"
depends="perl perl-timedate perl-ipc-run"
+checkdepends="bash"
makedepends="perl-dev docbook-xsl docbook-xml perl-xml-sax libxslt-dev linux-headers"
subpackages="$pkgname-doc"
source="http://ftp.de.debian.org/debian/pool/main/m/moreutils/moreutils_$pkgver.orig.tar.xz
@@ -18,6 +19,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make PREFIX=$pkgdir/usr install