aboutsummaryrefslogtreecommitdiffstats
path: root/testing/n30f
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-29 13:10:57 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-29 13:11:43 +0000
commitef39d3f74fa9439b8e0d9cf717a28a44123791c2 (patch)
tree3c73026ba86fbe5c0f112136e89450de49d03faf /testing/n30f
parent801c0dadf364621bf3ae1a93b2f8620150465f6b (diff)
downloadaports-ef39d3f74fa9439b8e0d9cf717a28a44123791c2.tar.bz2
aports-ef39d3f74fa9439b8e0d9cf717a28a44123791c2.tar.xz
testing/n30f: modernize and add basic check
Add basic check as upstream doesn't provide a test suite.
Diffstat (limited to 'testing/n30f')
-rw-r--r--testing/n30f/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/testing/n30f/APKBUILD b/testing/n30f/APKBUILD
index 11d81437e0..c9d30b8eb5 100644
--- a/testing/n30f/APKBUILD
+++ b/testing/n30f/APKBUILD
@@ -2,22 +2,27 @@
# Maintainer: Camille Scholtz <onodera@openmailbox.org>
pkgname=n30f
pkgver=2.0
-pkgrel=0
-pkgdesc="a quick hack to display a png in a borderless and transparent non-wm-managed window"
+pkgrel=1
+pkgdesc="A quick hack to display a png in a borderless and transparent non-wm-managed window"
url="https://github.com/sdhand/n30f"
arch="all"
license="BSD"
-depends=""
depends_dev="cairo-dev libxcb-dev"
makedepends="$depends_dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/sdhand/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
make
}
+check() {
+ cd "$builddir"
+ ./n30f --help > /dev/null
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install