aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nim
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2018-02-15 01:01:36 +0100
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-15 13:05:25 +0000
commitd5700e15606bd8cc9c882ca4aeb4227a560f6776 (patch)
treee6d6534c8a1765957689feab22f7ec20011d2e1d /testing/nim
parent52e0e9deead84d62b5442628675e3d69b036abc5 (diff)
downloadaports-d5700e15606bd8cc9c882ca4aeb4227a560f6776.tar.bz2
aports-d5700e15606bd8cc9c882ca4aeb4227a560f6776.tar.xz
testing/nim: use libucontext for coros
Diffstat (limited to 'testing/nim')
-rw-r--r--testing/nim/APKBUILD7
-rw-r--r--testing/nim/nim-config-enable-ucontext.patch11
2 files changed, 15 insertions, 3 deletions
diff --git a/testing/nim/APKBUILD b/testing/nim/APKBUILD
index a0575cd3e4..a547c267ae 100644
--- a/testing/nim/APKBUILD
+++ b/testing/nim/APKBUILD
@@ -4,18 +4,19 @@
# WARNING: There may be breakages!
pkgname=nim
pkgver=0.17.2
-pkgrel=1
+pkgrel=2
pkgdesc="A systems and applications programming language"
url="https://nim-lang.org/"
arch="all !s390x"
license="MIT"
checkdepends="sqlite-libs nodejs"
subpackages="$pkgname-doc nimsuggest niminst"
+depends="libucontext-dev" # used by nims compiler
source="https://nim-lang.org/download/$pkgname-$pkgver.tar.xz
$pkgname-csources-$pkgver.tar.gz::https://github.com/nim-lang/csources/archive/v$pkgver.tar.gz
niminst-fix-paths.patch
nim-config-fix-paths.patch
- nim-config-fix-coro.patch"
+ nim-config-enable-ucontext.patch"
builddir="$srcdir/$pkgname-$pkgver"
# Don't run tests on armhf, it'd take eternity...
@@ -82,4 +83,4 @@ sha512sums="7b4ed1eb1e9067ce72b76b95c43ec74eb38f04611776c174ba6a697254a9253fed61
4a8f1e87bd96ab33998b0d3415c0ba9560b78795e0396d8af8b588a93c23477097f2c5388b4e612fbc142b490480326b394a933c805a3585cd6f3d7e8390e3e6 nim-csources-0.17.2.tar.gz
4ab36c5d8772567ba09b536e3dd91ddcf253892056751318ccbfce7ac24f0a646bfcd94f5dadc823c9a8394bea9614fede20c1805638052ebdbe7b5bafba4f05 niminst-fix-paths.patch
813eb4cb93b0e9f12cb7666bef65c583390008ec09bc850f43f621688dc809bc51c105898095a8ef6316fbef49ac657a7abc75d74ad7b8cb3919c8f1a721af02 nim-config-fix-paths.patch
-bc1158d06a7ea667a0fb48b054fc3e1c5e2026260443ffa4b3958f65ea2899b72b8365b77906ebe7b33500c6442405fdc9177767001a0d9a70c67b7689fbcd36 nim-config-fix-coro.patch"
+5a21039dfcb2a49ccefb22c8d77a757b23a0f0f79046cb6a96862e44d1ef92bd7739dc412dfc1d464a564d5b06cc9365bcc27df26f13234dd985d33378d6fd39 nim-config-enable-ucontext.patch"
diff --git a/testing/nim/nim-config-enable-ucontext.patch b/testing/nim/nim-config-enable-ucontext.patch
new file mode 100644
index 0000000000..87216497be
--- /dev/null
+++ b/testing/nim/nim-config-enable-ucontext.patch
@@ -0,0 +1,11 @@
+diff -ruN a/config/nim.cfg b/config/nim.cfg
+--- a/config/nim.cfg 2018-02-15 00:45:38.251038499 +0100
++++ b/config/nim.cfg 2018-02-15 00:46:48.937858896 +0100
+@@ -231,3 +231,7 @@
+
+ # Configuration for the Tiny C Compiler:
+ tcc.options.always = "-w"
++
++# Enable libucontext
++gcc.options.linker %= "-lucontext"
++llvm_gcc.options.linker %= "-lucontext"